0

I am trying to set up OP25 on a Raspberry Pi 3 B running a Ubuntu 18.04 LTS (lubuntu-core desktop). The software installs fine, however I cannot get any sound out of the Pi, via HDMI or from the analog output. Here's what I have tried.

  1. aplay -l returns aplay: device_list:270: no soundcards found...

  2. Tried removing pulseaudio and alsa, reinstalling, does nothing.

  3. Tried reconfiguring hdmi/3.5mm jack (sudo amixer cset numid=3 1), no result.

  4. Tried using inxi, no audio devices found.

  5. modprobe snd_bcm2835 returns [1948.563781] bcm2835_audio bcm2835_audio: Failed to get DT property 'brcm,pwm-channels'

  6. Tried adding dtparam=audio=on to config.txt, no result.

  7. Tried speaker-test, no result.

The Pi itself is not defective, when I installed Ubuntu MATE the sound worked fine. My preference is to have the server running lubuntu-core, as I only need minimal features.

Any advice will be much appreciated.

New contributor
Alex A is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Have you looked into the boot FAT partition where there are some configuration files? There you can enable or disable drivers. It might be something there you need to change. – Anders Mar 26 at 22:18
  • @Anders I have not, will try that. Thanks! – Alex A Mar 26 at 23:36

Your Answer

Alex A is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.