2

I'm trying to install BricsCAD v13 for 64-bit on Xubuntu 16.04, however it has several unresolved 32-bit dependencies. I was able to solve them all except libgtk2.0-0:i386.

In order to install it, I first run the following command to dispose of the 32-bit packages:

sudo dpkg --add-architecture i386

sudo apt-get update

Then I try to install the package with the following command:

sudo apt-get install libgtk2.0-0:i386

But the terminal returns the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libatk1.0-0:i386 libgail-common:i386 libgail18:i386
Suggested packages:
  gvfs:i386
The following NEW packages will be installed:
  libatk1.0-0:i386 libgail-common:i386 libgail18:i386 libgtk2.0-0:i386
0 upgraded, 4 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/2.101 kB of archives.
After this operation, 7.635 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package libatk1.0-0:i386.
(Reading database ... 227989 files and directories currently installed.)
Preparing to unpack .../libatk1.0-0_2.34.0-1_i386.deb ...
Unpacking libatk1.0-0:i386 (2.34.0-1) ...
dpkg: error processing archive /var/cache/apt/archives/libatk1.0-0_2.34.0-1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libatk1.0-0/changelog.Debian.gz', which is different from other instances of package libatk1.0-0:i386
Preparing to unpack .../libgtk2.0-0_2.24.32-4ubuntu1_i386.deb ...
Unpacking libgtk2.0-0:i386 (2.24.32-4ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/libgtk2.0-0_2.24.32-4ubuntu1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libgtk2.0-0/changelog.Debian.gz', which is different from other instances of package libgtk2.0-0:i386
Selecting previously unselected package libgail18:i386.
Preparing to unpack .../libgail18_2.24.32-4ubuntu1_i386.deb ...
Unpacking libgail18:i386 (2.24.32-4ubuntu1) ...
Selecting previously unselected package libgail-common:i386.
Preparing to unpack .../libgail-common_2.24.32-4ubuntu1_i386.deb ...
Unpacking libgail-common:i386 (2.24.32-4ubuntu1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libatk1.0-0_2.34.0-1_i386.deb
 /var/cache/apt/archives/libgtk2.0-0_2.24.32-4ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I know how to get back to normal so that the package system is correct again. But I would like to be able to install the 32-bit version of said package to be able to install BricsCAD v13, but it seems that the system conflicts with having the same package in both architectures.

Thanks for your help

New contributor
Myzras is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1

As you can see from error messages the file conflicts are only for documentation files.

So you can force installation of both packages with:

sudo dpkg -i --force-all /var/cache/apt/archives/libatk1.0-0_2.34.0-1_i386.deb
sudo dpkg -i --force-all  /var/cache/apt/archives/libgtk2.0-0_2.24.32-4ubuntu1_i386.deb

and finally run

sudo apt-get install -f
sudo dpkg-configure -a

to have all things fixed.

  • Now I have been able to install it. Thank you. Could you explain to me why this error occurred? I don't understand conflicts between package documentation. – Myzras Mar 27 at 11:13
  • It is quite simple - both 32-bit and 64-bit deb-packages contain the same changelog.Debian.gz files. As usual only packages of only single CPU architecture are installed. – N0rbert Mar 27 at 11:20
  • OK, thank you very much for your help N0rbert. – Myzras Mar 27 at 11:27

Your Answer

Myzras is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.