12

Things were working fine for the first three weeks on the new notebook. Then, it stopped recognizing the audio board in a Dell G3 15 3590 (service manual) (audio specs).

I've disabled the secure boot, reinstalled plug audio, fed several different commands into the terminal, but it continues to not give any option for audio output aside from "dummy output".

After the mic and speaker output options disappeared in Configurations, leaving me with only "dummy output" as an option.

I tried:

  1. Reinstalled Pulse Audio and rebooted.

  2. Disabled Secure Boot.

  3. Ran tests with Dell technical support to confirm that the video and audio board and drivers are working, during boot up.

  4. Opened the terminal and ran sudo apt-get install pavucontrol pavucontrol then entered configuration profile to set configuration to analog stereo out, only to find "dummy output" as the only option again.

  5. Opened the terminal and ran sudo alsa force-reload.

  6. pulseaudio -k && sudo alsa force-reload had no effect.

  7. BIOS -> disable audio -> boot to Ubuntu -> restart -> BIOS -> enable audio -> boot to Ubuntu did not work. I still have "Dummy output" as the only sound output option.

  8. In accordance with instructions given on this conversation threat, I ran "inxi -Fxz && arecord -l && dmesg | grep snd" the result was: Command 'inxi' not found, but can be installed with: sudo apt install inxi

  9. I went onto the dell site to see if I could download a new driver for the Realtek ALC3254 but the only drivers that I could find on the site are only for Windows 10.

  10. Regarding the question about updating the bios. I dropped into the bios, audio section and headphone and speaker output are all checked as on. I am sorry but I don't understand how I would update the bios. What I see in the audio section of the bios are 3 options: bios defaults; factory settings; custom user settings. I was thinking of maybe changing to bios defaults and saving, but decided I'd better not start screwing around with bios until I know exactly what I was doing. Would that be something worth trying?

  11. installed inxi. Ran inxi -Fxz. It reads: `` Audio: Card-1 NVIDIA Device 10fa driver: snd_nda_intel bus-ID 01:00.1 Card-2 Intel Cannon Lake PCH CAVS Driver: sof-audio-pci bus-ID 00:1f.3 Sound: Advanced Linux Sound Architecture v: k5.0.0.-1043-oem-osp1

12 (April 12 - one month with no sound on brand new Dell G3 purchased with Ubuntu 18.04) Following Wikihow instructions on how to install a new kernel. After following steps 1-5, then typing sudo apt-get install ukuu i get a message saying it can't find ukuu

  1. Installed Kernel 5.5.9. Nothing changed. Still only getting dummy audio.

``

Dell technical support walked me through some tests to confirm that the audio board and driver is working fine, but they do not provide software support for Ubuntu.

I have now given up on Ubuntu completely. I will now move on to Mint. I have come to the conclusion that, for a lay person with average computer stills Ubuntu is incompatible with the Dell G3 and it is, therefore, a waste of time and money to purchase it with the Ubuntu installation.

7
  • Thank you. My PC is really a Dell G3 15 3590
    – Brian Mier
    Mar 27, 2020 at 12:28
  • 1
    a) Thank you for the details! It makes a solution much easier to find. b) Please go to each of the comments you added above & click Delete at the end of each to make room for more comments. c) Comments are our channel to you; when you have new info, please use edit to put it in the Question. d) #8 is a command specific to Unity Desktop; 18.04 uses GNOME3 Shell instead, unless you specifically installed Unity Desktop or retained it after an upgrade from 16.04 to 18.04. If you didn't specifically install or retain Unity Desktop, please click edit and delete 8) in your question.
    – K7AAY
    Mar 27, 2020 at 15:18
  • 1
    e) Please update the BIOS if you have not done so already as per dell.com/support/article/en-us/sln317706/… . Have you updated the BIOS? Please click edit and advise if you did. f) Your audio is not in the NVIDIA GeForce but instead is by the Realtek ALC3254 processor per dell.com/support/manuals/us/en/19/g-series-15-3590-laptop/…
    – K7AAY
    Mar 27, 2020 at 15:22
  • 2
    You're not alone w/ Realtec ALC3254 audio trouble - see askubuntu.com/search?q=ALC3254 & github.com/thesofproject/linux/issues/1877 Since at least 1 report was w/Ubuntu 19.10, testing with 19.10 will not help. Reverting to an older kernel did help, though; see askubuntu.com/questions/1218058/ubuntu-19-10-audio-driver-issue . Please consider that. Also, please run inxi -Fxz && arecord -l && dmesg | grep snd , highlight the results, copy that text, return here, click edit & paste the text into the end of your question.
    – K7AAY
    Mar 27, 2020 at 15:35
  • I am now wondering if I should try to install an older kernel. If so, does anyone have any recommendations? I need audio for my job.
    – Brian Mier
    Mar 31, 2020 at 14:43

6 Answers 6

8

Im using Ubuntu 18.04 Dell G3 3590 i7 series

I just follow the instruction here and fixes my problem

Edit /etc/default/grub

sudo vi /etc/default/grub

Find the line starting with GRUB_CMDLINE_LINUX_DEFAULT and append snd_hda_intel.dmic_detect=0 to its end. For example:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.dmic_detect=0"

Update grub configuration

sudo update-grub

Reboot

https://askubuntu.com/questions/1218058/ubuntu-19-10-audio-driver-issue/1238287#1238287

3
  • It worked on my dell g3 i5 9300H. Sep 28, 2020 at 16:18
  • Thank you so much. this worked for me :)
    – Sukeshini
    Dec 25, 2020 at 4:42
  • Just created an account here to vote for this answer and say thanks! I spent a few frustrating hours trying to get my Dell Laptop speakers working with Ubuntu and this solution finally worked!
    – Shayan
    Apr 1, 2021 at 10:48
1

--- UPDATED VERSION ---

As of Nov. 29 of 2020, update on Ubuntu 20.04 with latest kernel of 5.8.0-25-generic is working as expected with all internal sound working. Basically if you modified your grub with snd_hda_intel.dmic_detect=0, erase that or other modifications you made and keep the system fresh.

Update and upgrade with apt and now it is working with the internal mics and speakers.

So basically, update your vanilla 20.04 with latest kernel and updates and should work.

--- OLD REVISION ---

THIS IS WHAT WORKED FOR ME,

DELL G3 3590 is certified in Ubuntu 18.04 ONLY. It's very weird that later versions break functionality in this laptop.

The Dell G3 3590 version I have is the revised one (2019 version) but I guess the older 3590 version should work as well.

Do not install Ubuntu 20.04 or other version except 18.04 on this notebook.

I just did a Fresh install and at first sound wasn't working, then a Automatic Update at first boot (it's common when fresh install to get an update) added the sound and microphone working. If not, just apt-get update && apt-get upgrade

Then I added additional drivers for Nvidia and is working nice.

UPDATE On February aprox. a new version of ubuntu was released (18.04.4) and it has an optional upgrade called HWE that contains newer kernel and stuff. My solution worked but in some point, audio from the headphone jack was missing.

running sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04 solved this issue. So I have fresh install ubuntu 18.04.4, updated it and finally updated to HWE and have all sound working! internal and external as well.

WHAT A RIDE!!!

1
  • Weird. I have a Dell Inspiron 7590 and on Ubuntu 21.04 with kernel 5.11.0-22-generic but I still can't have the speakers work out of the box. dmic_detect=0 is stlll needed to have speakers working, but it disables the mic. Jun 30, 2021 at 23:24
0

Same problem here. Debian 10 installed on a Dell G3 15 3590 with audio issues using Realtek ALC3254. I've found a page with a lot of information . The best I've found so far to fix it is in the page below (in french but easily translated) but I didn't succeed, I think I screwed up some steps...

https://doc.ubuntu-fr.org/audio_intel_hda#dell

If the first elementary tests did not fix you audio, they suggest to: modify the file /etc/modprobe.d/alsa-base.conf or if it doesnt exist I've found that you can also create a local.conf file with sudo privilege here /etc/modprobe.d/local.conf

=> add the following line at the end of the file: options snd-hda-intel model=headset-mic probe_mask=0x103

See the line: Inspiron 15-5578 | ALC3253 | options snd-hda-intel model=headset-mic probe_mask=0x103 (Fonctionne: haut-parleurs interne, mic. interne, sortie écouteurs. Ne fonctionne pas: entrée(mic) écouteur)

This is the best I've found so far to fix it.

-

It is likely due to the Realtek driver not correctly working on Linux. But I don't know if it is possible to fix this driver on linux? who could do that ? where to ask ? I've tries to use bluetooth headset with microphone but it doesn't even want to configure it.


Hope This will help a little bit ? Let me know

Bye

0
0

I had a similar issue, probably around the same time - No audio in laptop speakers or headphones, but sound plays in screen (HDMI connection), and it was resolved in about 2 months, on its own. My analysis can be found in this answer.

The question is - What was the kernel version at the time you probably started getting this issue? You can check that by using

zgrep 'install linux-headers' /var/log/dpkg.log* | sort | cut -f1,2,4 -d' '

If the timeline of this issue matches mine, as in you started experiencing issue with 4.15.0-99-generic kernel update, or close, then I would suggest going back to the original kernel version (that you had before manually installing 5.5.9) and update to the latest kernel that is available for your system, instead of a particular kernel, i.e. 5.5.9, that you installed to resolve the issue but may or may not be compatible with your system, yet.

0

Thanks!

I had no sounds (speakers and headphones) in my Dell Latitude 3510 with Realtek ALC3204 after installing Ubuntu 20.04 LTS

I have tried a lot of different solutions without any result

After all your solution also worked for me!

sudo nano /etc/default/grub

Find the line starting with GRUB_CMDLINE_LINUX_DEFAULT and append snd_hda_intel.dmic_detect=0 to its end.

For example:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.dmic_detect=0"

Update grub configuration

sudo update-grub
-1

same problem here. Using Linux Mint,18.

The kernel I've installed was the 5.0, and the sound worked fine.

When I upgraded to 5.3, the audio stopped working.

Comparing the modules that was loaded in each kernel (lspci -k) I noticed that audio module was not the same, the kernel 5.3 was using sof-audio-pci driver.

Searching, I discovered that solution:

I've just got new HP Spectre x360 15-DF1033DX, installed Arch and got stuck with Audio. No output/input, no sound.

I used to change /etc/default/grub to have this line

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet splash acpi_backlight=vendor acpi_osi='!Windows 2013' acpi_osi='!Windows 2012' snd_hda_intel.dmic_detect=0 "

Then run in terminal

grub-mkconfig -o /boot/grub/grub.cfg

Then reboot.

Link of the solutuion: https://bbs.archlinux.org/viewtopic.php?id=251157

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.