1
frederick@frederickpina:~$ sudo apt-get upgrade -y
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libreoffice-base : Depends: libreoffice-common (>= 1:6.4.0~beta1-2~) but 1:6.3.5-0ubuntu0.19.10.1 is installed
                    Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                    Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
                    Depends: libuno-sal3 (>= 5.1.0~alpha) but it is not installed
                    Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                    Depends: uno-libs-private but it is not installed
                    Breaks: libreoffice-common (< 1:6.4.2~rc1~) but 1:6.3.5-0ubuntu0.19.10.1 is installed
 libreoffice-base-core : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                         Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                         Depends: libuno-sal3 (>= 5.1.0~alpha) but it is not installed
                         Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                         Depends: uno-libs-private but it is not installed
 libreoffice-base-drivers : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                            Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                            Depends: libuno-sal3 (>= 5.3.0~alpha) but it is not installed
                            Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                            Depends: uno-libs-private but it is not installed
 libreoffice-calc : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                    Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
                    Depends: libuno-sal3 (>= 5.3.0~alpha) but it is not installed
                    Depends: libuno-salhelpergcc3-3 (>= 3.6.0~beta) but it is not installed
                    Depends: uno-libs-private but it is not installed
                    Breaks: libreoffice-common (< 1:6.4.2~rc1~) but 1:6.3.5-0ubuntu0.19.10.1 is installed
 libreoffice-common : Breaks: libreoffice-core (>= 1:6.4~) but 1:6.4.2-0ubuntu0.19.10.1 is installed
                      Breaks: libreoffice-style-tango (>= 1:6.4~) but 1:6.4.2-0ubuntu0.19.10.1 is installed
 libreoffice-core : Depends: libreoffice-common (> 1:6.4.2) but 1:6.3.5-0ubuntu0.19.10.1 is installed
                    Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                    Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                    Depends: libuno-sal3 (>= 6.4.0~beta) but it is not installed
                    Depends: libuno-salhelpergcc3-3 (>= 3.6.0~beta) but it is not installed
                    Depends: uno-libs-private but it is not installed
 libreoffice-draw : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                    Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                    Depends: libuno-sal3 (>= 5.3.0~alpha) but it is not installed
                    Depends: libuno-salhelpergcc3-3 (>= 3.6.0~beta) but it is not installed
                    Depends: uno-libs-private but it is not installed
                    Breaks: libreoffice-common (< 1:6.4.2~rc1~) but 1:6.3.5-0ubuntu0.19.10.1 is installed
 libreoffice-gnome : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                     Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
                     Depends: libuno-sal3 (>= 5.1.0~alpha) but it is not installed
                     Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                     Depends: uno-libs-private but it is not installed
 libreoffice-gtk3 : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                    Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
                    Depends: libuno-sal3 (>= 5.1.0~alpha) but it is not installed
                    Depends: uno-libs-private but it is not installed
 libreoffice-impress : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                       Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                       Depends: libuno-sal3 (>= 5.3.0~alpha) but it is not installed
                       Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                       Depends: uno-libs-private but it is not installed
                       Breaks: libreoffice-common (< 1:6.4.2~rc1~) but 1:6.3.5-0ubuntu0.19.10.1 is installed
 libreoffice-java-common : Depends: libjuh-java but it is not installed
                           Depends: libjurt-java but it is not installed
                           Depends: libridl-java but it is not installed
                           Depends: libunoil-java but it is not installed
                           Depends: libunoloader-java but it is not installed
 libreoffice-math : Depends: libreoffice-core (= 1:6.3.5-0ubuntu0.19.10.1) but 1:6.4.2-0ubuntu0.19.10.1 is installed
 libreoffice-report-builder : Breaks: libreoffice-common (< 1:6.4.2~rc1~) but 1:6.3.5-0ubuntu0.19.10.1 is installed
 libreoffice-report-builder-bin : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                                  Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
                                  Depends: libuno-sal3 (>= 5.1.0~alpha) but it is not installed
                                  Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                                  Depends: uno-libs-private but it is not installed
 libreoffice-sdbc-firebird : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                             Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                             Depends: libuno-sal3 (>= 5.1.0~alpha) but it is not installed
                             Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                             Depends: uno-libs-private but it is not installed
 libreoffice-sdbc-mysql : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                          Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                          Depends: libuno-sal3 (>= 4.2.0~rc1) but it is not installed
                          Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                          Depends: uno-libs-private but it is not installed
 libreoffice-sdbc-postgresql : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                               Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
                               Depends: libuno-sal3 (>= 4.1.0~alpha) but it is not installed
                               Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                               Depends: uno-libs-private but it is not installed
 libreoffice-writer : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                      Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                      Depends: libuno-sal3 (>= 5.3.0~alpha) but it is not installed
                      Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                      Depends: uno-libs-private but it is not installed
                      Breaks: libreoffice-common (< 1:6.4.2~rc1~) but 1:6.3.5-0ubuntu0.19.10.1 is installed
 python3-uno : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
               Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
               Depends: libuno-sal3 (>= 5.4.0~alpha) but it is not installed
               Depends: libuno-salhelpergcc3-3 (>= 3.6.0~beta) but it is not installed
               Depends: uno-libs-private but it is not installed
 ure : Depends: uno-libs-private (= 1:6.4.2-0ubuntu0.19.10.1) but it is not installed
       Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
       Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
       Depends: libuno-purpenvhelpergcc3-3 (>= 1.4.0) but it is not installed
       Depends: libuno-sal3 (>= 5.3.0~alpha) but it is not installed
       Depends: libuno-salhelpergcc3-3 (>= 3.6.0~beta) but it is not installed
       Recommends: libjuh-java but it is not installed
       Recommends: libjurt-java but it is not installed
       Recommends: libridl-java but it is not installed
       Recommends: libunoloader-java but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
frederick@frederickpina:~$ 
  • Related: askubuntu.com/questions/1164480/… – Raffa Mar 26 at 17:52
  • Looks like you tried to install the wrong version of LibreOffice. If you are in the habit of using -y with apt, you are disabling protections that try to warn you about mistakes like these. Better to install the version in the Ubuntu repositories that's already tested to work with your release of Ubuntu. – user535733 Mar 26 at 18:03
3

The problem is with libreoffice-math. If you remove that one the rest will install perfectly okay. Try this:

sudo dpkg --purge libreoffice-math libreoffice

sudo apt-get -f install

sudo apt-get update

sudo apt-get dist-upgrade

That should fix it and the rest of all your LibreOffice apps should work just fine.

| improve this answer | |
  • Thanks rkl -- I had the same error today, and this solution worked. I now have LibreOffice 6.4.2.2 on my Kubuntu 18.04 system. Cheers! – protonic Mar 26 at 23:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.