1

Here's a problem I have: I step away from my laptop, a notification/message arrives (e.g., an email), Gnome Screensaver activates (i.e., the clock screen), I return to my computer and swipe the touchpad to show the screensaver/clock screen in order to see if any notifications are present but none are displayed on the screensaver/clock screen because the email message arrived before the screensaver activated.

This problem could be solved if I could engage the screensaver/clock screen before stepping away from my computer. I can do this if I lock the screen, but I don't wan't to lock the screen and force me to have to enter a password on return.

Is there any way to manually engage the screensaver/clock screen (preferably by keyboard shortcut) without locking the screen?

  • Using Gnome. I can enable the lock screen with CTRL+L. I would like to also have the option of enabling the screensaver/clock screen without locking. Perhaps not possible. I'm trying to solve the problem I presented; maybe there is a different solution. – G.W. Mar 26 at 15:22
  • @PRATAP? Far as I know there is version GNOME. How do you describe the version that is nothing else but just GNOME? – G.W. Mar 26 at 15:43
0

OS - Ubuntu 19.10

Run the below command

gsettings set org.gnome.desktop.screensaver lock-enabled false

Create a shortcut with below command

gdbus call --session --dest org.gnome.ScreenSaver --object-path /org/gnome/ScreenSaver --method org.gnome.ScreenSaver.SetActive true

enter image description here

enter image description here

enter image description here


enter image description here

| improve this answer | |
  • I already have that gsetting set to false. Thank you for your answer, but does your method enable me to cause the screensaver to activate at a time of my choosing? My read of it seems to just control whether lock is enabled or not and not when the screensaver activates. – G.W. Mar 26 at 17:37
  • @G.W Can you check the .gif added in the Answer.. – PRATAP Mar 29 at 7:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.