Edit: The problem in Teams has been solved by Microsoft since the question was asked: Teams screen sharing sessions now capture the mouse pointer also on Linux computers. This makes this question asking for a workaround obsolete. However, the solutions presented in the answers may still be applicable for other applications.

I'm doing screen sharing with Microsoft Teams on Linux. My mouse pointer is not visible to the people I share the screen with. This is a known shortcoming of the Linux version: https://docs.microsoft.com/answers/questions/3222/mouse-pointer-not-visible-when-sharing-screen.html

I'm searching for workarounds. Today I have used a terminal window, resized it to the smallest possible size and told people 'look at the upper left corner of this window' while dragging that terminal window across the screen to point out the parts of the screen that I want to draw attention to. I want to find a better workaround.


  1. Use an image with transparency. An improvement over dragging around a terminal window would be to drag around an image of a mouse pointer with transparency around the mouse pointer. The tool 'display' from imagemagick had this property that when displaying e.g. a png image with transparent pixels, it would show the screen content behind those transparent pixels. The current version on ubuntu 18.04, however, shows an opaque checkerboard pattern instead. Is there another image display tool in Ubuntu that can still display transparency in an X11 window?

  2. Have some application display a bright-colored circle (or something else) at the position of the mouse pointer on and off in intervals. Is there an application that can do this?

I am using Ubuntu 18.04, with the default desktop environment (the default desktop is called "ubuntu" on 18.04, it is based on gnome but preconfigured by canonical to resemble the discontinued "unity" desktop).

  • 1
    I've not used it but there is tool called key-mon which has an option --follow_mouse to Show the mouse more visibly.
    – meuh
    Mar 26, 2020 at 17:20
  • 1
    key-mon doesn't work, it eats all the mouse click when in follow_mouse mode. There is an issue for this, but nobody seems to be working on the problem: github.com/zackp30/key-mon/issues/138
    – Enno
    Apr 23, 2020 at 8:05
  • After upgrading to Pop!_OS 20.04 (and a new version of Gnome) the problem no longer occurs. Looks like it was fixed.
    – Enno
    May 28, 2020 at 11:10

2 Answers 2


I have found this workaround, based on an answer to a SE question and first suggested by a user on a Microsoft discussion forum. It works for me in linux mint 19.3 MATE, Ubuntu 20.04, and 18.04.4 (tested both ubuntu versions on a vmware machine).

  • Download find-cursor from https://github.com/arp242/find-cursor
  • Inside the folder of this library, type make and sudo make install.

    • You can ignore warnings (mostly related to docs).
    • If you see an error, you probably need to install some X11 libraries:

      sudo apt install libx11-dev libxdamage-dev libxrender-dev libxext-dev
  • In a terminal, use this command:

    find-cursor --repeat 0 --follow --distance 1 --line-width 16 --size 16 --color red

The following gif shows the pointer on Ubuntu 18.04 after I followed the previous steps. Notice that the mouse is not visible until I used the find-cursor command (recording with Kazam but it also happens with teams). So far, the mouse works normally (I use it to take notes and draw lines on xournal while I screenshare with teams).

find-cursor on ubuntu for mikewhatever

  • LM is not Ubuntu. It is off topic here. Apr 30, 2020 at 16:55
  • The answer is off topic because it has not been tested on Ubuntu. It may or may not work, there is no way to tell without testing. You are obviously free to up or down vote, same as myself. May 1, 2020 at 16:56
  • 1
    Alright then, since you say it works on Ubuntu, I'll retract the down vote. However, this site is about Ubuntu and official derivatives. All other distros are off topic. You probably don't like that, but rules are rules. May 1, 2020 at 20:59
  • I just tested this solution on Ubuntu 18.04.4 LTS running natively rather than in a VM and it worked perfectly. Extremely on topic. Thank you!
    – alkanen
    May 4, 2020 at 9:09
  • Worked on Xubuntu 18.04.4 LTS as well. Thanks!
    – Lam
    Jun 3, 2020 at 10:34

For the moment I have solved this by executing in a terminal

gsettings set org.gnome.settings-daemon.peripherals.mouse locate-pointer true

Since then, I can highlight the mouse pointer by pressing and releasing the Ctrl key. Orange circles appear around the mouse pointer when I do this. These are visible to other people during screen sharing.

I had also tried key-mon --follow_mouse as suggested in a comment. This places a permanent yellow circle around the mouse, but then I can not perform mouse clicks anymore, i.e. they have no effect anymore until I terminate key-mon again.

  • This produces the error message No such key “locate-pointer”
    – Enno
    Apr 23, 2020 at 8:05
  • @Enno I'm sorry that it does not work for you, but it works inside the parameters of the question, which are ubuntu 18.04 and default desktop environment. You probably have a newer ubuntu version or another desktop environment.
    – T. Herzke
    May 1, 2020 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.