2

There are many similar questions in the forum but I couldn't find a solution. I've purchased a new Lenovo Ideapad S145 and installed ubuntu 19.10. And I can't get my touchpad to work. I've tried adding multiple commands to grub's GRUB_CMDLINE_LINUX_DEFAULT and of course ran sudo update-grub and rebooted and it didn't seem to work.

When I'm pressing the f6 key, it shows a touchpad icon with a small 'x'.

My Kernel version is 5.3.0-42-generic.

My xinput command result is:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C           id=9    [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]

Thanks in advance :)

5

I had this same issue. The problem is with the kernel. The kernel hasn't detected the touch pad. Firstly edit the kernel boot parameters. This is what i did to solve it - EDIT: It is recommended to take a backup using cp /etc/default/grub /etc/default/grub.bak

  1. sudo nano /etc/default/grub
  2. Edit GRUB_CMDLINE_LINUX_DEFAULT to GRUB_CMDLINE_LINUX_DEFAULT="quiet i8042.nopnp=1 pci=nocrs"
  3. Now save and exit.
  4. Run sudo update-grub

The next steps will be to patch the kernel

  1. Now run git clone https://github.com/pavlepiramida/elan_i2c_dkms.git
  2. After that install make and dkms, so run sudo apt install make dkms
  3. Now run cd elan_i2c_dkms
  4. After that run sudo dkms install .
  5. Finally, run reboot

Now, once you reboot, the touch pad should be working perfectly fine! Glad I could help!

4
  • This works for me in Lenovo 14iiL05 for Ubuntu 20.04 Aug 21 '20 at 13:31
  • Helped me with lenovo ideapad s145 on ubuntu mate 20.04
    – devxplorer
    Feb 27 '21 at 12:57
  • this does not work. Sorry.
    – Mohamed
    Mar 5 '21 at 22:25
  • @Mohamed I've seen many solutions for this problem and none worked, but this definitely did, so yea. Try again. Dec 7 '21 at 12:03
0

The Lenovo IdeaPad S145 is not in the list of Linux-compatible hardware that Lenovo maintains.

It's likely to be the drivers, which may be too new to be available in the 19.10 kernel, or just not available. Have you tried fwupd to see if drivers are available?

There is good info on how to use it at the LVFS project page as well as the ArchWiki .

2
  • There aren't any ideapads in that list. I believe they just haven't tried for compatibility certification for the ideapad line. Doesn't mean the machines won't work with Linux, just means they haven't targeted that.
    – Wildcard
    Aug 24 '20 at 7:47
  • Well I'm having a ton of problems with 20.04 so far on my IdeaPad 3 Gaming: - Can't switch between nvidia and integrated AMD graphics after installing nvidia drivers - Can't adjust screen brightness - Touchpad not working
    – Matt Welke
    Sep 3 '20 at 16:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.