0

Everything was working fine previous day when i turn on my laptop I'm stuck on restart loop unable to boot after GNU GRUB screen. My Ubuntu did updated previous day and i selected Restart later option

When i select Advance Option for Ubuntu i get 4 options as seen in image below

[Image][1]

Selecting both recover mode options i get

Loading Linux 5.3.0-42-generic ...
Loading initial ramdisk ...

then black screen then my system restart

and selecting other options i get black screen then my system restart

I have Tried this but don't work for me

Some posts suggested this solution On GRUB menu Press 'e' and changing quiet splash nomodeset Pressed Ctrl + X

still get black screen and computer restart

I have Ubuntu IOS on usb but the installing Ubuntu i don't get reinstalling Ubuntu while keeping my data

Recovered my data but fresh installation also have same problem after Update

My system: Dell inspiron i3 15 3567 Intel HD 520 integrated

Thanks in advance

Edit 1:

i tried to apply these solutions but none works for me Ubuntu 18.04.2 boot stuck on purple screen after updates

After trying to fix my problem i know my Ubuntu Break (hang to purple screen) after these updated is installed and computer is restarted as shown in image below

Ubuntu update list

I really cant do any more debugging because i need my laptop for work

System info : 
     Intel(R) Core(TM) i3-6006U CPU @ 2.00GHz
     VGA compatible controller
     product: Skylake GT2 [HD Graphics 520]
     vendor: Intel Corporation

9
  • Welcome to AskUbuntu, to salvage your data, create system rescueCD and cope your home directory to another media. Or use fsarchiver to backup the entire partition then you can try anything. – Sadaharu Wakisaka Mar 26 '20 at 1:41
  • @SadaharuWakisaka but i can't go pass the GNU GRUB screen system keep restarting – Numan Hassan Mar 26 '20 at 2:21
  • From the GRUB Additional Options menu, try and boot the -40 kernel. Does that fully boot? Report back. Start comments to me with @heynnema or I may miss them. – heynnema Mar 26 '20 at 2:49
  • System rescue CD/USB is another way to boot your computer, it's independent. Enter BIOS and select external device, but you need another computer to create it. – Sadaharu Wakisaka Mar 26 '20 at 5:36
  • @heynnema I recovered my data using USB boot and did the fresh Ubuntu installation then after update same problem this time i get purple Screen instead of black screen – Numan Hassan Mar 27 '20 at 1:42
1

I have a Dell Inspiron 17 5767 which was exhibiting the same issue(s). A clean Ubuntu 18.04.4 install works fine. But as soon as I updated packages, when this jumped to kernel 5.3.0.28-generic, my laptop stopped booting, and froze at "loading initial ramdisk". Using dis_ucode_ldr did not help. Updating the Dell BIOS did not help. When adding debug options to the kernel command line, nothing was displayed.

This link solved the problem for me: Ubuntu 20.04 black screen after installing, no booting "The problem is with UEFI. To fix it you can turn off PPT in the UEFI/BIOS options and enable Legacy Boot."

When I disabled PPT and enabled Legacy Boot, my Dell laptop recovered and can now boot successfully. Hopefully this might help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.