1

I have an older dell laptop that I put ubuntu on a while back and it's never charged properly since. It was a windows7 upgraded to w10 machine originally. It's fully up to date with bios updates. The PSU works fine on other laptops with windows. The battery charges fine on other laptops with windows. If I put my old SSD back in with windows 10 on it, it starts charging again.

This is not a dual boot, it's ubuntu only.

When the machine starts up, the battery light flickers on for a second, then off, then on for about 4 seconds, then off indefinitely. The battery percentage never goes up, but it does go down and shuts off if I unplug the power.

With the computer off, it does the same thing when I plug the power in. Light comes on for about 3-4 seconds, then shuts off and stays off.

This thing is plugged in all the time, but it would be nice to be able to charge the battery so I could move it around my house on occasion.

I've tried "resetting" the machine by shutting down, removing the battery, holding in the power button for 30 seconds, plugging it in, booting up, shutting it down, unplugging it, installing the battery, booting it up.

UBUNTU sees the battery and shows the percentage. For the 4 seconds the charge light is on, it shows an estimated charge time. But when the light shuts off, the charge time goes away and it just says "charging".

I may pull the drive and put the windows drive back in just to make sure it does in fact charge... I know it did 6 months or so ago as I had put the drive back in to install latest windows updates so the drive stays up to date.

0

The issue appears to have been the battery was worn out. I went into bios to see what it said for charging and adapter wattage, while on that screen, I unplugged the power and let it go until it died. It got down to 1% then stayed there for about 20 minutes and finally shut off. Then I plugged the power back in and it charged up to 43%. However, when I unplugged the power with ubuntu up, it only lasted 15 minutes, then shut down.

I ordered a new factory sized battery, it came at 61% charged, so I ran it until it got down to 2% and shut it down, then plugged the power back in. After an hour or two, the charge light shut off and when I powered it up, it showed 100%.

I then bumped the screen to 100% bright and had a movie playing in full screen via vlc for over 3 hours until it got down to 2% again and I charged it back up.

This is what I get from upower:

Latitude-E5420:~$ upower -i /org/freedesktop/UPower/devices/battery_BAT0 native-path: BAT0 vendor: Samsung SDI model: DELL 5CGM4A7 serial: 30030 power supply: yes updated: Fri 27 Mar 2020 10:50:59 PM CDT (37 seconds ago) has history: yes has statistics: yes battery present: yes rechargeable: yes state: fully-charged warning-level: none energy: 51.3708 Wh energy-empty: 0 Wh energy-full: 51.3708 Wh energy-full-design: 48.84 Wh energy-rate: 0.0111 W voltage: 12.477 V percentage: 100% capacity: 100% technology: lithium-ion icon-name: 'battery-full-charged-symbolic' History (charge): 1585367459 0.000 unknown History (rate): 1585367459 0.000 unknown

And from acpi -V

Latitude-E5420:~$ acpi -V Battery 0: Full, 100% Battery 0: design capacity 4400 mAh, last full capacity 4628 mAh = 100% Adapter 0: on-line Thermal 0: ok, 25.0 degrees C Thermal 0: trip point 0 switches to mode critical at temperature 107.0 degrees C Cooling 0: Processor 0 of 10 Cooling 1: LCD 14 of 15 Cooling 2: Processor 0 of 10 Cooling 3: x86_pkg_temp no state information available Cooling 4: Processor 0 of 10 Cooling 5: intel_powerclamp no state information available Cooling 6: Processor 0 of 10

The pack states that it's 65WH and 5500mah, so I guess I'm not getting full capacity. Then again, it was a $30 pack off amazon. It's far better than the 5 minutes I was getting before and the lack of charging.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.