0

I edited the yaml file in /etc/netplan to include the name servers. It applied without error. However when I do nslookup > server I get the loop back (127.0.0.1) I need it to be my DNS servers as this is joined to the domain. I had also changed the link of the /etc/resolv.conf but when I reboot it, it goes back to the old settings. Some help would be greatly appreciated.

1

removed the link and created a /etc/resolv.conf and added the name servers. That fixed the issue.

| improve this answer | |
0

Ubuntu 18.04 always uses systemd-resolved as a local resolver, and the nameservers specified in netplan config are fed to resolved rather than listed directly in /etc/resolv.conf. It is not recommended to bypass this by making /etc/resolv.conf a file.

| improve this answer | |
  • But according to this site, you're supposed to disable systemd-resolved when joining a domain....computingforgeeks.com/… – JordenD Mar 27 at 13:58
  • I know of no reason why you should need to disable resolved to join a domain, and this third-party how-to doesn't explain. Unless you have a specific problem when using resolved (in which case, please file a bug report!), I still recommend keeping it enabled. – slangasek Mar 29 at 1:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.