0

Yesterday I installed some games, by using both the package manager and the software center. Some games are now properly installed, but their launch shortcut icons do not appear in the 'Games' section of the applications main menu.

Is this a problem with my OS installation, or it is a lacking feature of some packages I downloaded?

However, I would like to see all the games I downloaded appearing in the 'Games' category. I am looking into folders and hidden folders to find their desktop configuration files.

It seems that here there are no questions and answers related to this precise issue/bug.

  • FYI: Menu items not being shown is not because of any OS installation issues, its more likely a choice made by the packager of the programs you installed, and whether or not they included files that cause it to appear, and where it'll appear in standard menus. LXDE used by Lubuntu 18.04 LTS is now very old (it was the last release where Lubuntu used it) so it follows old standards packagers won't consider anymore. – guiverc Mar 25 at 4:55
1

After some searching, I have found in /home/user/.local/share/applications the desktop config files I was looking for.

You can simply copy and paste them on your desktop to have a simple shortcut. Visit this page on the official Wiki site for further detailed instructions regarding desktop config files.

As I wanted to add new items in 'Games' main menu category,

  1. I downloaded Alacarte package, probably the best program for editing the main menu, as properly suggested here: How do I edit applications panel menu in Lubuntu?

    sudo apt-get install alacarte
    
  2. I went to Main Menu -> Preferences -> Main Menu -> Games; alternatively, you can run Alacarte from the Terminal:

    alacarte
    

    Here an example of Alacarte interface:

enter image description here

  1. I selected New item
  2. Then I chose
    • the name of the new item,
    • the icon (by clicking on the empty icon and adding the path of the image I wanted to use as the new icon)
    • and the command line to be executed (I did not know all the exe commands of the new packages: so I opened the desktop config files stored in /home/user/.local/share/applications with Leafpad and copied the command line that follows the Exec= entry).
|improve this answer|||||
  • I am new with Ubuntu and it took me some time and effort to do this customisation: I hope other beginner users will find such instructions helpful, having little command lines. – corradini riccardo Mar 24 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.