0

For a few days now, I can get no sound out of my Dell laptop on Ubuntu 18.04.4. The 'Sounds' settings only shop the option 'Dummy output'. I have checked with headsets, it is the same. I have a Windows on my laptop in dual-boot, and the sound is just fine there, so I believe it is not the fault of the hardware.

In the last few days I've been Googling all possible ways to fix this issue, and I've found the followings:

  • Disabling the sound in BIOS the re-enabling it does nothing
  • Force-reloading alsa in various ways (e.g. pulseaudio --kill; sleep 2s; sudo alsa force-reload ; pulseaudio --start) does nothing
  • Reinstalling all soundbases e.g. with sudo apt-get --purge remove linux-sound-base alsa-base alsa-utils && sudo apt-get install linux-sound-base alsa-base alsa-utils also with sudo apt install --reinstall pulseaudio pulseaudio-module-x11 does nothing

For the troubleshooting :

  • The command lsmod | grep snd_hda_intel shows that I indeed have the intel module:

    snd_intel_nhlt         20480  2 snd_hda_intel,snd_soc_skl
    snd_hda_codec         131072  5 snd_hda_codec_generic,snd_hda_intel,snd_hda_codec_realtek,snd_soc_hdac_hda,snd_soc_skl_hda_dsp
    snd_hda_core           90112  11 snd_hda_codec_generic,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda,snd_soc_skl_hda_dsp
    snd_pcm               102400  10 snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
    snd                    86016  12 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm,snd_rawmidi````
    
  • lspci -nnk shows nothing related to audio

  • aplay -l and pacmd list-cards both fail to find any sound card
  • The sudo lshw -c sound command finds the card alright:
multimedia
description: Multimedia audio controller
product: Cannon Lake PCH cAVS
vendor: Intel Corporation
physical id: 1f.3
bus info: pci@0000:00:1f.3
version: 10
width: 64 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list
configuration: driver=snd_soc_skl latency=32
resources: irq:17 memory:ed318000-ed31bfff memory:ed100000-ed1fffff 
  • Now I also tried to open alsamixer with sudo alsamixer, however I get the result cannot open mixer: No such file or directory. I do not know if this is a normal error message or is it because I've been messing up a few things during trying everything in the last few days.

Maybe somebody can help me out how to get my Ubuntu to find my sound card again?

1
  • It... worked. Based on the answer you linked, I found an error message in dmesg telling me that there is an invalid setting with my audio system. After adding the kernel boot parameter in your link, now I do not get the error message anymore, and what's more, the sound is back. I do not really get what went wrong and why I had to do all of this, so it feels like a band-aid fix, but for now, I am fine. Thanks.
    – user1056925
    Commented Mar 23, 2020 at 9:00

1 Answer 1

0

I had a similar problem. My issue is if I go to the Windows boot and then restart the computer, Ubuntu will have no sound. And it will continue to have no sound until I actually shut down the PC, the turn it on into the Ubuntu boot. This is the only way I was able to "fix" my problem.

1
  • I've already suspected this to be an issue with dual-boot, but it did not work for me. However, the comment of @guiverc worked
    – user1056925
    Commented Mar 23, 2020 at 8:58