0

When i press FN+SEARCH on my laptop (FN+F9) the KDE dekstop freaks out (opens the run menu (ktunner), same as ALT+F2, closes it and opens it several times VERY fast), after that the META or SUPER key doesnt open the Kickoff menu until i reboot or kwin --replace. All other FN keys work as intended. Is there a fix for that ?

Hardware: Canonical certified DELL Inspiron 15 3585 Ryzen 5 2500U Vega 8

Software: Kubuntu 19.10 (latest available updates as of 2020-03-22)

I used xev to see what it does, It seems it does this, and does it A LOT:

MotionNotify event, serial 40, synthetic NO, window 0x3000001,
    root 0x4cc, subw 0x0, time 60253, (142,31), root:(142,64),
    state 0x0, is_hint 0, same_screen YES
  • I think that MotionNotify has to do with the movement of the touchpad pointer/cursor and nothing to do with pressing Fn+F9. What do you see in System Settings > Shortcuts > Global shortcuts > Run command? On my Dell Inspiron 15-3567 with Kubuntu 18.04, pressing Fn+F9 does bring up the krunner window but it doesn't misbehave. What happens if you just don't use Fn+F9 and instead stay with Alt+F2? – DK Bose Mar 22 at 15:04
  • ALT-F2 works as intended, settings you mentioned list: ALT+Space > ALT+F2 and execute command from clipboard ALT+SHIFT+F2 – Q00 Mar 22 at 15:13
  • I couldn't find out where Fn+F9 is set or how to disable it. I prefer to have Alt+Space to launch krunner and have never used Fn+F9 until I read your question. If everything else is working fine, just avoid using Fn+F9. – DK Bose Mar 22 at 15:37
  • But i accidentally hit it sometimes and it causes havoc, is there anything i can do to diagnose/troubleshoot it ? or disable its functionality ? The BIOS only gives me an option to disable FN keys ENTIRELY... – Q00 Mar 22 at 15:54
  • Follow this: reddit.com/r/kde/comments/fn1wf1. Maybe someone there can help. – DK Bose Mar 22 at 16:02
0

System Settings > Shortcuts > Global shortcuts > Run command

Disable all default shortcuts

I suggest remapping to ALT+=

| improve this answer | |
  • EDIT: Not working after reboot – Q00 Mar 22 at 20:11
0

Assuming that the problem you describe isn't because of something fundamentally wrong with your system (see later), here's one workaround:

  • Install xdotool using, in this order,
    • sudo apt update
    • sudo apt full-upgrade
    • sudo apt install xdotool
  • Open System Settings > Shortcuts > Custom Shortcuts. In there,
    • create a new global shortcut of type Command/URL
    • Name the shortcut whatever you like
    • In the Action tab, enter exactly xdotool key shift
    • In the Trigger tab, press the Input button and then press Fn+F9
    • You should get a pop-up complaining that the shortcut is in use. Click the Reassign button and then click Apply (in the lower right corner of the System Settings window).

From now on, whenever you press Fn+F9, nothing obvious will happen and this setting should survive a reboot.


If the change you made doesn't survive a reboot, I suspect you have other problems as well. One possibility is that one or more files in your home folder or its subfolders are owned not by you but by root. You can check with this command which may take a little while to complete: cd ~ && find . '!' -user $USER -ls. If you get back just the prompt, that means nothing is owned by root. If you get any hits, it's your job to evaluate each one and act appropriately.

Another possibility is that there's something else wrong with your system. Do you have the same problem if you create a new user?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.