0

I am having a problem getting Sonarr to post-process downloaded files, then move them to my Plex media folder. Sonarr runs as myuser and Sabnzbd runs as sabnzbd. Sabnzbd downloads to /home/sabnzbd/Downloads/incomplete and my Plex library resides at /mnt/sdc1/tv (in this case). I am running Ubuntu 19.10 and the target drive is NTFS.

This is in my Sonarr log:

20-3-21 08:45:47.6|Warn|ImportApprovedEpisodes|Couldn't import episode /home/sabnzbd/Downloads/incomplete/<episode name>/8a96bd8519ca4f0db9daf9234a4ae55c.mkv
[v2.0.0.5344] System.UnauthorizedAccessException: Access to the path is denied.

I wasn't sure, to what path the error was referring, so I ran this:

sudo chmod -R ugo+rw /home/sabnzbd/Downloads/
sudo chmod -R ugo+rw /mnt/sdc1/

To make sure both users can read and write to any sub-directory. That didn't help.

The perms look like this:

/home/myuser# ls -l /home/sabnzbd/Downloads/
drwxrwxrwx 30 sabnzbd sabnzbd 4096 Mar 21 08:50 complete

and

/home/myuser# ls -l /mnt/sdc1/
drwxrwxrwx 1 root root 4096 Mar 18 15:00  tv

I thought that maybe, adding myuser to the groups with permission would help. I ran:

sudo usermod -a -G root myuser
sudo usermod -a -G sabnzbd myuser
groups myuser

myuser : myuser root ...truncatedlist... sabnzbd

Sonarr is running as a service like this:

[Unit] 
Description=Sonarr Daemon After=network.target

[Service]
User=myuser
Group=myuser
ExecStart=/usr/bin/mono --debug /opt/NzbDrone/NzbDrone.exe -nobrowser
Type=simple
TimeoutStopSec=20
KillMode=process
Restart=on-failure

[Install]
WantedBy=multi-user.target

Finally, in Sonarr, I updated the path from /mnt/sdc1, to /home/myuser/ShowName but I'm getting the same error.

During this, I rebooted frequently.

Any thoughts on what I'm missing here?

2
  • Please provide OS/release details. (the file-system types in use may also be useful) – guiverc Mar 22 '20 at 3:33
  • Fair point, edited the op to add "Ubuntu 19.10" and "target drive is NTFS". – StackExchangeGuy Mar 22 '20 at 3:56
0

I removed 'user' and 'group' definitions from the service file (myuser for both). After a service restart, the move started working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.