1

i have installed two Arduino IDE in my Ubuntu one have installed form software application which have problem of accessing to mountable derives of my PC and by this post quid it don't solved:

sudo snap connect arduino:removable-media

this error:

so@so-notebook:~$ sudo snap connect arduino:removable-media
error: snap "arduino" has no plug named "removable-media"

and another by downloading the application file from Arduino website, which have problem in connecting to usb port like this:

Arduino: 1.8.5 (Linux), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

Error opening serial port '/dev/ttyACM0'. Try consulting the documentation at http://playground.arduino.cc/Linux/All#Permission

this problem solved by these codes of this instructions:

[sudo usermod -a -G dialout $USER][2]

[sudo chmod a+rw /dev/ttyACM0][2]

but in this situation one of my Arduino application can connect to hardware by USB port, but can not connect to mountable drives like this:

enter image description here

and another is vis versa. like this:

enter image description here

so how can fix it?

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.