5

I used to be able to use nautilus and go to the location bar and "ssh://[email protected]" into a remote server and do things like drag and drop files. However, that remote server added two-factor authentication with duo (e.g. if I ssh in a terminal, after giving my correct password I now have to do a duo 2FA.

Duo two-factor login for nouyang

Enter a passcode or select one of the following options:

 1. Duo Push to XXX-XXX-1234
 2. Phone call to XXX-XXX-1234

If I try to use ssh in nautilus, it just asks me for my password three times and then fails (or spins for a while and says "oops! unhandled error message: timed out when logging in").

I would really like a graphical interface, since the alternative is scp but now each time I use scp I also have to go through this process. Is there any way to do so?

GNOME nautilus 3.26.4
3
  • Sounds like you're asking for a file manager that would bypass what Duo is doing? Or somehow, integrate with Duo? I also have to use Duo for 2FA and I have never heard of that. And I think this seamless integration sounds great but it would defeat the purpose of 2FA, which is to prove that not only you know your password but that you have something physical on you (i.e., your phone). Would be nice if Duo passes automatically if it's near your computer (for example), but I have never heard of it (so far).
    – Ray
    Commented Mar 25, 2020 at 7:07
  • 2
    Does sshfs work? So you could mount the folder from the terminal and then work with it from nautilus
    – pLumo
    Commented Mar 25, 2020 at 8:37
  • Ah, I just want to login only once with duolingo have it persist for a while, so bypass it (kind of like with cookies in the browser). sshfs doesn't appear to let me launch a file manager, but I did learn something, so thanks! Commented Mar 30, 2020 at 5:24

1 Answer 1

2
+50

If all else fails, I have helped someone use FileZilla with Duo.

Install it with sudo apt install filezilla

If for some reason apt cannot find it, you can download it here

One complaint I have seen is having to input the password, and DUO code in every single time you go to transfer a file. The key is to go into the settings and change the simultaneous connections to "1".

File > Site Manager > Transfer Settings set "Limit number of simultaneous connections" to 1

That should keep the connection from automatically disconnecting after each transfer.

4
  • I want this to work so badly, but even with that setting at 1, it still keeps asking for a password... still if no one responds today I'll award it! Thanks! Commented Mar 30, 2020 at 5:09
  • EDIT: Not sure what changed, tried multiple times a half hour ago... now it works, hurray! Commented Mar 30, 2020 at 5:25
  • 1
    Glad to hear that it is working. I know how frustrating it can be when prompted each time
    – Gordster
    Commented Mar 30, 2020 at 6:41
  • Sad. I hate this Filezilla thingy, but I was trying to figure out a fast way to do the same. Not with Duo, but to my accounts on the clusters where I work. Sadly enough, MobaXterm on Windows does it perfectly, which sucks because I would have to change to this OS (not an enemy of Win, it's just a lot of work to reinstall all my workstation). THX anyway
    – runlevel0
    Commented Jul 29, 2022 at 12:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .