0

I am trying to install XRDP onto Ubuntu, I have tried many different steps and keep coming across the same error:

E: Sub-process /usr/bin/dpkg returned an error code (1)

I am brand new to Linux over all as I just downloaded yesterday. My end goal is to use my desktop with windows while running my laptop with Ubuntu as a VM. I am planning on using mRemoteNG as the access point on my desktop (Windows)... if that's relevant. I also have Remmina installed on the laptop (Ubuntu).

I am also new to this so maybe that's showing here...

I have pasted below my Ubuntu install

Version of Ubuntu Distributor ID: Ubuntu Description: Ubuntu 18.04.4 LTS Release: 18.04 Codename: bionic

system GE62 6QD (Default string) processor Intel(R) Core(TM) i7-6700HQ CPU @ 2.60G
memory 16GiB System memory disk 1TB HGST HTS721010A9 There's also a GTX960M that doesn't show

  • xrdp packages.ubuntu.com/search?keywords=xrdp&searchon=names ... Install : sudo apt install xrdp → The universe repo must be enabled. – Knud Larsen Mar 21 at 20:21
  • I went ahead and pulled the repositories for Universe and I did multiverse but it says I already have installed. After this I went ahead and tried to re-download and got same error. gabriel@gabriel-GE62-6QD:~$ sudo add-apt-repository universe 'universe' distribution component is already enabled for all sources. gabriel@gabriel-GE62-6QD:~$ sudo add-apt-repository multiverse 'multiverse' distribution component is already enabled for all sources. Edit: Did I do it correctly? If not, please correct me. Thank you for your response! – Gabriel Mar 21 at 21:21
  • Strange. Please upload a copy of /etc/apt/sources.list , as sources.list.txt to Dropbox .... and edit your question to include a shared link to the file. – Knud Larsen Mar 22 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.