0

I had a issue with apt-get update, which python somehow prevented it from gather updates. I autoremoved python, and managed to do a update. But, when I did a reboot, the server lost network connection. Just reviewed the netplan configuration file, and it looked okay as it is, but at the top of the file it said "configuration=disabled" (if I remember correctly, at this point my server is in Live CD) I tried sudo netplan apply, and a error displayed "unknown operation", which I suppose that Netplan was dependant to Python..?

I know I did a good f*** up, but is there a way to undo the autoremove and somehow reinstall python? Currently, I booted into Live USB installation, and looked for some repair options, but so far I haven't found any, tried googling for solution for a about an hour now.

Thanks.

  • Your repair options depend upon 1) Your Ubuntu release, and 2) Whether you removed, Python2, Python3, or both. See /var/log/apt for the list of what you removed - that would be helpful, too. Also, more information about your original apt-get error would be useful to determine if repair is worthwhile. – user535733 Mar 20 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.