0

I recently switched from Windows 7 to Linux. My choice fell on Ubuntu. Unfortunately, there is a problem with my Brother DCP-7030 (it's a printer, scanner and copier in one). I downloaded and installed drivers according to the instructions on Brother's official website:

https://support.brother.com/g/b/downloadlist....lang=pl&prod=dcp7030_all&os=128&flang=English

Installation of the printer drivers went smoothly and it works correctly. Then I installed drivers for the scanner, but this one doesn't work. Ubuntu doesn't see it. I searched the net looking for a solution. After installation, I did as suggested by the device producer in this thread:

https://support.brother.com/g/b/faqend.aspx?c...&ftype3=100258&faqid=faq00100617_000&ot=eu_ot

But it doesn't work for me. I also found a few topics in our forum, but the latest one is from 2012 and advices there also doesn't work.

And something strange is going on when I trying to use a "simple scan". When I run it and press the "scan" button, it displays "connecting to the scanner ..." and it lasts indefinitely. When I tried to close the program, it froze.

The device is connected to the computer through the USB. The printer and scanner were working properly on windows, so this is not a device fault. So I am asking you for help.

p.s. sorry for possible language mistakes ;)

  • Is the udev rule setup? – WinEunuuchs2Unix Mar 20 at 12:38
  • I don't know. Can you tell me how can I check it? – Kano Mar 20 at 13:24
  • Try google search with keywords linux, udev, brother and scanner. You should get lots of results. – WinEunuuchs2Unix Mar 20 at 23:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.