6

so I just uninstall KDE Neon because of a problem and tried to install it again but i got integrity: Problem loading X.509 certificate -65 and the boot stuck/freeze. I thought it was KDE Neon error, but then I tried installing ubuntu 19.10 and got the same error. I even clean install my windows and delete other partitions, but it doesn't do anything, I keep getting the same error. What should I do ? Thanks in advance.

I've tried with 18.04 too and same result, strange, these iso files have no problem before.

I cleared my USB using RosaImageWriter, formatted it, and then I made my USB bootable using PowerISO, and choose install with safe graphics. The error still persists, but now I can boot Ubuntu 19.10 without getting stuck.

I get a black screen with this error:

[    3.173272] integrity: Problem loading X.509 certificate -65 
[    3.173311] integrity: Problem loading X.509 certificate -65 
_
1
2

I had the EXACT same problem! At the end of the story, after several failed attempts to install Ubuntu on my machine, I started to suspect the HDD (which was very unpleasant, since I had just bought the PC). In the end, the problem was actually the HDD.

To run disk tests on your HDD, boot to a virtual Ubuntu machine and open the terminal.

To discover the path of your Linux partition, type:

sudo fdisk -l

The output should contain something like this:

Device         Start       End   Sectors   Size Type 
/dev/sdb1       34        32767      32734    16M Microsoft reserved
/dev/sdb2      32767 1025777663 1025744896 489,1G Microsoft basic data
/dev/sdb3 1025777663 1026828287    1050624   513G EFI System
/dev/sdb4 1026828287 1953523711  926695424 441.9G Linux filesystem

The partition that is giving problems, in my case, is the /dev/sdb4.

Then run:

sudo badblocks -sv /dev/sdb

And wait to see if there is errors in your partition. If yes, now you know what is causing the problem.

After this, run:

sudo fdck /dev/sdb4

If you notice an error in your HDD, you should change it as soon as possible. Hope this helps!

2
  • how much time does badblocks takes to run on 1 tb hard disk sata – beta_me me_beta Jun 2 '20 at 2:18
  • it's a reaaaly slow process! just be patient, it will work eventually haha @beta_meme_beta – Carolina Naccarato Jun 8 '20 at 12:51
0

I fixed this message into my laptop BIOS. All you need to do is :

  1. Disable the Secure Boot

  2. Reset Setup Mode ( this function is in Bios )

After that, just exit Bios and save changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.