6

I was upgrading Ubuntu to 12.04 from 11.10 (x64) and right in the middle of the package installation I had a freeze (not Ubuntu's fault) forcing me to do a hard reset of my pc. Now the Ubuntu installation is completely broken I can only get access via recovery mode. I already tried apt-get update && apt-get upgrade and the option to fix broken packages. Nothing changed.

So I'm wondering if its possible to fix the broken packages, or maybe to restore before the upgrade?

5
  • Backup the data before proceeding – Tachyons Apr 14 '12 at 1:52
  • While in recovery mode did you run a fsck check on your file system to make sure it was OK? (When this happened to me fsck found something to fix.) – irrational John Apr 14 '12 at 2:20
  • Thanks for the advise but I haven't any important data to backup, so I can safely try anything. I think I manage to restore the system partially using "apt-get dist-upgrade" Im not sure if this was ok, the only problem now is that I can only boot in tty. I will try the fsck and see what happens. – mrcrow85 Apr 14 '12 at 2:37
  • We need more information. What error message are you getting with apt-get install -f? – Panther Apr 14 '12 at 3:18
  • Ok, I ran fsck and everything seems ok. I reinstalled xserver and the propietary radeon drivers and the GUI is back. However, the integrity of the system seems heavily damaged, it keeps showing me messages about "errors in the system" to report, applications that can't be launched and the left and upper menus of the desktop disappearing. So, in this case what should be the optimal solution? reinstall ubuntu from scratch? – mrcrow85 Apr 14 '12 at 3:32
5

In the end the only solution I could find was to do a clean ubuntu 11.10 install and then upgrade to 12.04 via terminal in tty1 using the command sudo do-release-upgrade –d to avoid possible graphic issues as the first time. Anyway, thank you guys for your time.

You can also try a sudo apt-get -f dist-upgrade

1
  • I had a power out and a dud laptop battery during update. I was able to boot into recovery, ran fsck then got back to a login screen, couldnt log into the system. ctrl + alt + f2 and rant apt update which failed, but got a good pointer, ran dpkg then back to apt, its currently upgrading from the the terminal, i can live with that if it finishes. – Chris Feb 14 '16 at 23:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.