1

Thinkpad x1 carbon 7th gen. Sound gone. Only dummy output available. Soundcard not detected

I have a habit of running sudo apt-get install dist-upgrade from time to time and i also update the system whenever system updater prompts me to. After the last update i have my system's volume gone. In fact the soundcard is not getting recognized at all. I have tried to sudo alsa force-reload. I have tried this. I have tried everything that comes on first page of google if i type "Ubuntu 18.04 sound gone shows only dummy output."

I have tried uninstalling alsa and pulseaudio

also, when i run sudo pulseaudio -k i get:

E: [pulseaudio] core-util.c: Home directory not accessible: Permission denied E: [pulseaudio] main.c: Failed to kill daemon: No such file or directory

Can somebody guide me to get the sound back?

1
  • I have the exact same problem on Ubuntu 19.10. Not only did sound/mic stop working, but also I cannot reboot/shutdown anymore. It gets stuck at "systemd-shutdown[1]: Detaching DM devices". – Doc Mar 20 '20 at 10:29
1

I had the exact same issue on Ubuntu 18.04 ... Very disturbing . I got my speaker back by doing what was written here https://superuser.com/a/1509313/1151609

but i still have issues with my microphone and with the Bluetooth ...

Those updates are excessively annoying ...

2
  • 1
    nothing works but the linked answer. i had tried everything. even google search's second page. NOTHING BUT THIS WORKED – MiloMinderbinder Mar 21 '20 at 20:02
  • I am glad it solved your problem. You can also use the previous kernel when you boot (the 5.3.0-40 one). It should work too. – Elias Mar 23 '20 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.