0

I search and found help for this subject but I have question because it doesnt work for me:

I have Lubuntu 19.10 with LXQt and I want to run this in startup:

setxkbmap "us,gr" -option "grp:alt_shift_toggle"

(if I run it in terminal it works).

I created a file named swap.desktop, with content

[Desktop Entry]
Name=swapping
Exec=setxkbmap "us,gr" -option "grp:alt_shift_toggle"

and put it in /etc/xdg/autostart

I rebooted and:

  1. it didn't work
  2. it renames automatically my file to: swapping.

Any help? Thank you!

  • 1
    Welcome to AskUbuntu, /usr/bin/setxkbdmap you need a full path where the script outside of your user path executes, e.g. cron or root. – Sadaharu Wakisaka Mar 20 at 1:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.