I have installed Ubuntu 16.04 at a further PC and I am trying to install ESET antivirus software. The only information I could get from the firm is a file eset_nod32av_64bit_cs.linux, a note that I should make it executable and run it and system requirements according to https://help.eset.com/eav_linux/4/en-US/ud_install.html?ud_ena_intro_requirements.html, mainly:

  • kernel 2.6.x and later
    • GNU C Library 2.3 or newer
    • GTK+ 2.6 or newer
    • LSB 3.1 compatibility recommended

I have set the 'executable' permission to that file, executed it as the root and I have got the message, the translation of it is:

Please install the following files or packages: libc6:i386, /lib/ld-linux.so.2.

I have not found anything like it in the Ubuntu software center. How should I install them? Thanks!

(A remark for a moderator:I accidentally created two accounts; how do I merge them?)

  • Installation error on Debian 10.2 x64 (ignore the first answer) Mar 19, 2020 at 18:07
  • Should I try 'sudo dpkg --add-architecture i386 && apt-get install libc6-i386' at the new PC? Mar 20, 2020 at 4:29
  • @ steeldriver: Chromium is crashing every several seconds at the PC from which I am sending this my second comment. I cannot use that PC to edit this question, I need that further PC, correctly protected. Mar 20, 2020 at 4:59

2 Answers 2


At least a part of the question - how to get rid of the message about the need to install libc6: i386 - has a solution that the steeldriver brought me to. He led me at the ESET support page. I see that my 'Recommended updates (xenial-updates)' are checked, similarly as 'Recommended updates(trusty-updates)' for another Linux distribution in that manual and I hope the alerts

me@furtherPC:~$ software-properties-gtk
/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py:40: PyGIWarning: Gdk was imported without specifying a version first. Use gi.require_version('Gdk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import GObject, Gdk, Gtk, Gio, GLib
/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py:40: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import GObject, Gdk, Gtk, Gio, GLib
don't matter. Software Updater tells that my Ubuntu 16.04 is up to date. The recommended commands
sudo apt-get update
sudo apt-get upgrade
worked without warning. After the furtherPC restart
as_a_root@furtherPC:/home/me$ sudo dpkg --add-architecture i386 && apt-get install libc6-i386
[sudo] password for as_a_root: 
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
has not worked but
as_a_root@furtherPC:/home/me$ sudo apt-get install libc6-i386
has downloaded and installed 10.4 MB files. Now running that installation file
as_a_root@furtherPC:/home/me/pathESET$ ./eset_nod32av_64bit_cs.linux
No protocol specified
(eset_nod32av_64bit_cs.linux:5531): Gtk-WARNING **: cannot open display: :0
will not raise the message that libc6: i386 is needed, however it reports further errors. Perhaps I understand correctly that
me@furtherPC:~/pathESET$ dpkg-query -W libgtk-3-bin
libgtk-3-bin    3.18.9-1ubuntu3.3
means that the furtherPC has the required GTK + 2.6 or newer installed. I have also asked ESET support and will tell the result here.

  • There is a mess with my identity. I (= user:165175) have written and am responsible for both this question and the first answer. Mar 22, 2020 at 20:12

Continuation from the answer 1.:

From the response from ESET support, it was inferred that it was needed

as_a_root@furtherPC:/home/me$ export DISPLAY=:0.0

. I tried the result and the installer went to run it

 as_a_root@furtherPC:/home/me$ echo $DISPLAY
 as_a_root@furtherPC:/home/me/pathESET$ ./eset_nod32av_64bit_cs.linux

However, the ESET window display problems, that were one of the reasons for the reinstallation, persist. 7.4.2020, ESET shows all the necessary information.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .