I've successfully installed Firefox as a snap package (done by default by installing it through Ubuntu's "software center"). It does work, and give me a more recent version of Firefox than the one available through APT.

I'm running through problems when downloading files, though:

  • Saving them in /tmp/ does not work, since the snap version of Firefox uses a different filesystem than the one of the host computer, hence Firefox and non-snap applications see different content in /tmp/.

  • The open with dialog application does not see most applications, in particular it doesn't see evince nor libreoffice, which I've installed through APT. The dropdown defaults to "Url Handler Script (default)", which apparently does nothing with my files.

  • If I save a downloaded file, the open containing folder button in the downloads list does not work. I'm guessing that it tries to open nautilus, but fails to do so because nautilus is a non-snap application.

Is there a way to make Firefox have normal interactions with my desktop and other applications, even though it's installed through snap?

  • I think these are open bugs: bugzilla.mozilla.org/show_bug.cgi?id=1535785 and bugzilla.mozilla.org/show_bug.cgi?id=1461759 and workarounds exist.
    – ignite
    Mar 19, 2020 at 13:30
  • Thanks. The first one is not really the problem I'm getting, but the second is. Unfortunately, " Opened 2 years ago Updated 4 months ago" :-(. Mar 19, 2020 at 14:25
  • 2
    The problem that your workflow is incompatible with snaps. Snaps are designed to not see /tmp or to interact with other applications. Snaps run confined - by design, snap applications cannot see your whole system, including /tmp, /mnt. /media, and network drives. Snaps applications can only see your /home (nobody else's) and their own /snap. There is a lot of discussion among developers right now about this issue, but no consensus on how to change snap design has yet emerged.
    – user535733
    Mar 19, 2020 at 15:01
  • Apparently bug 1461759 is supposed to be fixed, but I still have the issue with Firefox 104.0.2 on Ubuntu 22.04 – well except it should “System handler” instead of “Url Handler Script”. Last issue in the question seems to be fixed in Firefox 104 via bug 1772063
    – Didier L
    Sep 6, 2022 at 20:26

5 Answers 5


In Ubuntu 20.04, just:

sudo snap remove firefox
sudo apt install firefox

I'm not sure why Ubuntu thinks it is cool to switch to the snap version, it only brings problems.

Users expect the browser to download files and "open" them. If you now download a file that you open, you can't find any application for it. The list is simply empty.

I understand running applications in containers is the way forward, but this is a huge oversight.

In Ubuntu 22.04, the APT version of Firefox no longer exists (firefox is a transitional dummy package), only the snap version is provided in the main distribution. There are however PPA apt repositories maintained by Mozilla that allow installing Firefox through APT. Here's an example tutorial on How to install Firefox deb as APT. More on OMG Ubuntu.


Simplest way is to open Files and then go to Recent where you will find all the files you have recently opened.

Intuitively, you should be able to identify the file you downloaded

enter image description here

Other than that, in the topbar of FF is an Icon which relates to downloads. Left clisk with your mouse and you will be presented with files you have downloaded.

enter image description here

  • 1
    I know about the download icon, that's what I meant by "downloads list" in my last point. I get the list of downloaded files, but it's pretty useless: I can't open their containing directory in the file browser, and I can't open the files directly from there. Mar 19, 2020 at 14:11

Open software centre again and check firefox permissions, might have to allow. Second way if first does not work, uninstall snap version and install deb version.

  • I don't think permissions would solve my issues, but anyway, if I open the permissions window, activate all of them, then it seems I have no way to save my changes. No "save" button, only a "close" button, and if I click "close" and re-open, I get back to the old state. Mar 19, 2020 at 14:17
  • 1
    Installing the deb version via APT is an obvious workaround, but by default that would mean downgrading to a rather old version, or upgrading to a beta version. I couldn't find a PPA with the latest stable version :-(. Anyway, thanks for the hints. Mar 19, 2020 at 14:18
  • My firefox deb version is at 74.0. The snap version is only up to 74.0-3, not that older.
    – crip659
    Mar 19, 2020 at 14:39
  • 1
    Weird, my version was 66 or so (given by apt policy after a successful apt update), but changing the Ubuntu mirror gave me a version 74, which indeed is the latest stable. So I have to conclude that using snap to install Firefox on Ubuntu is just a way to get the same software but with a broken integration in the system :-\. Thanks anyway. Mar 20, 2020 at 16:45

You are missing the xdg-desktop-portal packages. Simply install them via the Terminal as shown below:

$ sudo apt update
$ sudo apt install xdg-desktop-portal
  • How will this help with the snap issue? Jun 21, 2022 at 17:15
  • Description: desktop integration portal for Flatpak and Snap xdg-desktop-portal provides a portal frontend service for Flatpak, Snap, and possibly other desktop containment/sandboxing frameworks. This service is made available to the sandboxed application,, looks like a solution indeed. I switched to the apt firefox, so I can't check right now how well it works. Jun 22, 2022 at 16:33
  • 2
    I had it already installed so it does not seem to be enough…
    – Didier L
    Sep 6, 2022 at 20:27

In Firefox navigate to about:preferences and scroll down until you reach the section labeled Downloads. There should be an option to select you downloads location.

  • 1
    Sorry, but that does not answer my question. I know how to chose the downloads location, my problem is that I can't use /tmp/, and I can't use the "open with" feature. Mar 19, 2020 at 14:20
  • Ah sorry, I don't know about that. Mar 19, 2020 at 19:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .