3

My sound used to work as expected but after some small update all I find now is "Dummy output" as my output device. Below is the output of lspci -v | grep -A7 -i "audio"

00:1f.3 Multimedia audio controller: Intel Corporation Cannon Lake PCH cAVS (rev 10)
    Subsystem: Dell Device 0949
    Flags: bus master, fast devsel, latency 32, IRQ 16
    Memory at a5518000 (64-bit, non-prefetchable) [size=16K]
    Memory at a5200000 (64-bit, non-prefetchable) [size=1M]
    Capabilities: <access denied>
    Kernel driver in use: snd_soc_skl
    Kernel modules: snd_hda_intel, snd_soc_skl, sof_pci_dev
--
01:00.1 Audio device: NVIDIA Corporation Device 10fa (rev a1)
    Subsystem: Dell Device 0949
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at a3080000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

but when running alsamixer I can only see the second one there

also running lspci -knn | grep Audio -A3 doesn't show the first intel driver. output:

01:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:10fa] (rev a1)
    Subsystem: Dell Device [1028:0949]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

sorry if my post isn't organized it's my first

1

2 Answers 2

0

I had the same prb when I updated my software. And the prb was the driver used Kernel driver in use: snd_soc_skl is not correcte. I found the solution here : https://askubuntu.com/a/1217838/1058039

vim  /etc/modprobe.d/alsa-base.conf 

add in the end of file this line :

options snd-hda-intel dmic_detect=0 in the

blacklist snd_soc_skl driver through balcklist.conf

sudo vim  /etc/modprobe.d/alsa-base.conf

add in the end of this file this :

blacklist snd_soc_skl
1
  • The blacklist snd_soc_skl should probably go to sudo vim /etc/modprobe.d/blacklist.conf.
    – Vilda
    Nov 18, 2022 at 12:47
0

I had the same issue for a few days and I fixed it by referring the official PulseAudio documentation at

https://www.freedesktop.org/wiki/Software/PulseAudio/
The problem you've is in the PulseAudio layer, the
lspci
output shows that the audio hardware has been detected well by the system.

This was the part at

https://www.freedesktop.org/wiki/Software/PulseAudio/Desktops/KDE/
that fixed my issue.

One thing that can happen is that some other process "hogs" the audio device during PulseAudio startup. When this happens PA is unable to use the device until it is restarted. If PA is unable to open your hardware, you will automatically be given a "Dummy Output". As the name suggests, anything that is "Played" via this device is inaudible). This "Dummy Output" should be easily visible in both KMix and Phonon. If this happens, then you can debug which process is hogging the hardware via the command: sudo lsof /dev/snd/* /dev/dsp* (Note that apps which have the /dev/snd/control* devices open are unlikely to interfere).

I ran

lsof /dev/snd/*
to see that 'timidity' service had been hogging my sound card. Since I didn't need it, I removed it:
sudo apt purge timidity
and as soon as it was removed, the audio volume in the system tray got unmuted and Armin van Burren blared through my speakers.

As a side note, this timidity package got installed as part of kde-full kali metapackage, and so I suggest not to install a package unless you need it and to avoid meta packages.

Not the answer you're looking for? Browse other questions tagged .