After a prompted automatic software update and reboot, my screen received no signal after the purple splash screen. Before this my graphics card had been working with Ubuntu for 4+ years. Dropping down to a tty shell still had the screen off. I could still type commands in the tty shell or a terminal, such as opening video with xdg-open or rebooting.

The usual nomodeset flag still leads to a black screen with no tty. Changes to nouveau blacklisting does not fix the issue (nvidia drivers installed through apt-get blacklist the nouveau drivers automatically). I thought maybe the nvidia driver or kernel was updated during my software update. Every version of nvidia driver I've tried has the same issue (in combination with many older kernels as well). With a 4.3.X kernel I was able to get to a login screen but that caused a log in loop. (I tried older kernels because the only other issue I've found that looks similar is here: https://bugzilla.redhat.com/show_bug.cgi?id=1314492).

When I apt-get --purge remove nvidia* from a recovery shell I am able to boot and get a display with the nouveau driver. However I'm not even sure why the driver would be a problem; I don't believe I had updated the driver in almost a year.

I'm using Ubuntu 16.04 with kernel 4.4.0-176. My graphics card is a GTX 950.

EDIT: I'v tried installing 14.04, 18.04, and 19.10 fresh (in a partition) and installing both the nvidia drivers from the apt repository and installing manually (19.10 installs drivers automatically), and all resulted in the same black screen issue. To reiterate, even when doing CTRL+ALT+F[1-6] nothing appears on the screen whenever I have nvidia drivers installed, which is unique compared to other "black screen after splash screen" issues that I've seen online.

Back on my 16.04 install, I took a look at my software update log. It's possible my last shutdown was before the beginning of this log.

2020-03-03 06:33:26 status installed libc-bin:amd64 2.23-0ubuntu11
2020-03-03 06:33:26 status installed libarchive13:amd64 3.1.2-11ubuntu0.16.04.8
2020-03-03 06:33:26 status installed libc-bin:amd64 2.23-0ubuntu11
2020-03-04 06:42:47 status installed man-db:amd64 2.7.5-1
2020-03-04 06:42:47 status installed rake:all 10.5.0-2ubuntu0.1
2020-03-05 22:36:44 status installed skypeforlinux:amd64
2020-03-05 22:36:44 status installed desktop-file-utils:amd64 0.22-1ubuntu5.2
2020-03-05 22:36:44 status installed bamfdaemon:amd64 0.5.3~bzr0+16.04.20180209-0ubuntu1
2020-03-05 22:36:44 status installed gnome-menus:amd64 3.13.3-6ubuntu3.1
2020-03-05 22:36:44 status installed mime-support:all 3.59ubuntu1
2020-03-05 22:36:44 status installed hicolor-icon-theme:all 0.15-0ubuntu1.1
2020-03-11 06:27:47 status installed libc-bin:amd64 2.23-0ubuntu11
2020-03-11 06:27:47 status installed libsqlite3-0:i386 3.11.0-1ubuntu1.4
2020-03-11 06:27:47 status installed libsqlite3-0:amd64 3.11.0-1ubuntu1.4
2020-03-11 06:27:47 status installed libc-bin:amd64 2.23-0ubuntu11
2020-03-12 06:33:47 status installed firefox-locale-en:amd64 74.0+build3-0ubuntu0.16.04.1
2020-03-12 06:33:54 status installed hicolor-icon-theme:all 0.15-0ubuntu1.1
2020-03-12 06:33:54 status installed man-db:amd64 2.7.5-1
2020-03-12 06:33:54 status installed desktop-file-utils:amd64 0.22-1ubuntu5.2
2020-03-12 06:33:54 status installed bamfdaemon:amd64 0.5.3~bzr0+16.04.20180209-0ubuntu1
2020-03-12 06:33:54 status installed gnome-menus:amd64 3.13.3-6ubuntu3.1
2020-03-12 06:33:54 status installed mime-support:all 3.59ubuntu1
2020-03-12 06:33:54 status installed firefox:amd64 74.0+build3-0ubuntu0.16.04.1
2020-03-13 06:11:49 status installed update-notifier-common:all 3.168.10
2020-03-13 06:11:49 status installed flashplugin-installer:amd64
2020-03-15 18:22:51 status installed libc-bin:amd64 2.23-0ubuntu11
2020-03-15 18:22:51 status installed libxcb-xtest0:amd64 1.11.1-1ubuntu1
2020-03-15 18:22:51 status installed libc-bin:amd64 2.23-0ubuntu11
2020-03-15 18:23:00 status installed zoom:amd64 3.5.361976.0301
2020-03-15 18:23:00 status installed desktop-file-utils:amd64 0.22-1ubuntu5.2
2020-03-15 18:23:00 status installed bamfdaemon:amd64 0.5.3~bzr0+16.04.20180209-0ubuntu1
2020-03-15 18:23:00 status installed gnome-menus:amd64 3.13.3-6ubuntu3.1
2020-03-15 18:23:00 status installed mime-support:all 3.59ubuntu1
2020-03-15 18:23:02 status installed shared-mime-info:amd64 1.5-2ubuntu0.2
2020-03-17 09:10:33 status installed atom:amd64 1.45.0
2020-03-17 09:10:33 status installed desktop-file-utils:amd64 0.22-1ubuntu5.2
2020-03-17 09:10:33 status installed bamfdaemon:amd64 0.5.3~bzr0+16.04.20180209-0ubuntu1
2020-03-17 09:10:33 status installed gnome-menus:amd64 3.13.3-6ubuntu3.1
2020-03-17 09:10:33 status installed mime-support:all 3.59ubuntu1
  • Do you have grub installed? Did you try the nomodeset option? – starkus Mar 23 '20 at 14:08
  • ...also you could give blacklisting the nouveau driver a chance. – starkus Mar 23 '20 at 14:17
  • Yes, grub is installed. When I use nomodeset I still get a black screen with the nvidia drivers installed. I've also blacklisted the nouveau driver (installing the nvidia-drivers through apt-get automatically makes a blacklist in modprobe.d for the nouveau driverse). I've updated my question to reflect those two points. – elsherbini Mar 23 '20 at 14:40
  • Hm, strange. The last weeks I had the nvidia.run driver installed and wanted to see if I could just reinstall it, and then decided to uninstall it. But I had to reboot to multi-user.target with systemctl set-default multi-user.target to get it managed. After a reboot I could install, or uninstall it. Maybe you can get it fixed with purging nvidia* and installing it again in multi-user.target environment. To revert it you need to systemctl set-default graphical.target before rebooting. – starkus Mar 23 '20 at 14:50
  • 1
    Then it's maybe just some reinstallation and reconfiguration by the system because of some config files and some dependencies to gurantee system-integrity. I get those entries too, using the command you posted. Sorry. – starkus Mar 24 '20 at 18:57

There were two issues, the tty issue and a screen resolution issue.

tty issue:

The tty issue was solved by editing /boot/grub/grub.cfg to nolonger have the vthandoff.

# changed this
linux   /boot/vmlinuz-4.4.0-176-generic root=UUID=537b826a-d5eb-4697-a08e-05b0fb3f75a1 ro noprompt persistent quiet splash $vt_handoff
# to this
linux   /boot/vmlinuz-4.4.0-176-generic root=UUID=537b826a-d5eb-4697-a08e-05b0fb3f75a1 ro noprompt persistent quiet splash

Then, I was able to get into my tty shell even with the nvidia drivers installed.

resolution issue:

Afterwards, in my tty I could see in my /var/log/Xorg.0.log file that the resolution of my screen was being detected as 3840x2160. I knew that in the past I had halved this resolution, and had a hunch that my graphics card might not be able to do 4K. So I CTRL+ALT+F7 to go the the (black) window manager, hit CTRL+ALT+T to launch a terminal, and typed in xrandr --output HDMI-0 --mode 1920x1080 and my desktop appeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.