13

Ubuntu 19.10 (Eoan Ermine)

When not plugging in anything, my internal input and outputs work perfectly. When I plug in my headphones, which do not have microphone but only speakers, my input devices look like this (using pulseaudio volume control):

  • Internal Microphone (unplugged)
  • Microphone (plugged in)

Before plugging in my headphones, my input devices look like this:

  • Internal Microphone
  • Microphone (unplugged)

Now I think ubuntu thinks my headphones contain a microphone, but they don't. Selecting the Internal Microphone does not give any sound, because it says they are unplugged.

I got my headphones and internal speakers to work yesterday by pure luck, but now plugging it out and in again doesn't fix anything. I've also tried rebooting several times and muting one channel of both microphones.

If you need any other information, I'll be happy to include it!

EDIT:

It works sometimes, which is very weird. I have no idea how to consistently get it to work. Sometimes it will not work after rebooting a lot of times and booting with headset plugged in or not. And sometimes it just works for no reason.

1
  • Try yelling into your headphone speakers and see if it detects the Sound. – Danial Behzadi Mar 18 '20 at 14:31
12
sudo apt install alsa-tools-gui

hdajackretask

Select the appropriate sound card up top in Select a codec:

Then make the Black Mic (headphone jack) override Not connected

Lower right corner, select Install boot override

Image showing how

Then reboot and test

4
  • This worked for me. Had to select and configure the microphone via pavucontrol - but now finally it works. Thank you for your help. – advance512 Jul 16 '20 at 13:46
  • Well, at least a microphone appears in the sound settings now, but no luck actually getting it to detect sound – Jack M Sep 15 '20 at 13:35
  • This worked totally fine in Ubuntu 18.04. Thanks! – Macr1408 Jan 6 at 20:58
  • It enabled the headset microphone alright, but now I can't get the headset speakers to work, am I the onlyone? – Paulin Trognon Feb 11 at 11:41
1

Known bug since 2012. https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1025388

If you'd like, you can add yourself there to the number of users affected.

0

My workaround for this problem is to log-out or to sleep, then plug in my headphones, then login or wake up my computer. This keeps my input device as "Internal Microphone - Built-In Audio" while switching my output device to "Headphones - Built-in Audio". This has worked on 18.04 and 20.04, but it might work on other versions as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.