2

I recently updated firmware on my Thinkpad Carbon X1 (last gen, 7th I guess) and since (I'm not sure it is the cause of my problem, but it happens simultaneously), I only have a "dummy device" in sound configuration panel on Ubuntu 18.04. I tried a lot of stuff suggested around the web and still, the result of aplay -l is always no sound card detected. The output of lspci -nnk | grep -A2 Audio is :

Audio device [0403]: Intel Corporation Device [8086:9dc8] (rev 11)
    Subsystem: Lenovo Device [17aa:2292]
    Kernel driver in use: snd_soc_skl

Any suggestion how to fix this ?

1
  • Kernel is? uname -a please.
    – nobody
    Mar 18, 2020 at 13:56

2 Answers 2

2

Edit /etc/default/grub as root and add the next kernel parameter:

GRUB_CMDLINE_LINUX="snd_hda_intel.dmic_detect=0"

Save and then execute in terminal:

sudo update-grub

And restart...

The latest kernel update (5.3.0-42), while trying to fix things end up breaking them... This should fix it up again....

Ubuntu 18.04 audio disappeared after update

2

Thanks to all of you that answered and commented my question. While waiting for an answer here, I found someone on the web with the same problem that was advised to go and look here : https://bugs.launchpad.net/ubuntu/+source/linux-oem-osp1/+bug/1864061/comments/3. The two steps proposed there solved the issue :

  • add options snd-hda-intel dmic_detect=0 in the configuration file /etc/modprobe.d/alsa-base.conf
  • add blacklist snd_soc_skl in the config file /etc/modprobe.d/blacklist.conf

As this fixed my issue, I do not know if other solutions work as well, but I'm sure they do :). Thanks again!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .