I am experiencing some sound issues with my fresh install of ubuntu 19.10 on my Dell Inpsiron 7590. It has an ALC3254 sound chip.

The weird thing is, when running ubuntu from the install USB, the audio is working fine. After installation, the system only shows 'dummy output' for audio.

Using 'inxi -Fxz' for the installed version, showed me:

    Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_soc_skl 
    v: kernel bus ID: 00:1f.3 
    Sound Server: ALSA v: k5.3.0-42-generic

While the live version on the USB shows:

    Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
    v: kernel bus ID: 00:1f.3 
    Sound Server: ALSA v: k5.3.0-18-generic

This shows the loaded driver is different and the Sound Server version is slightly different. I checked alsa-base.conf between the two, and they show no difference.

On the installed version, all commands to show soundcards I tried, show no soundcards. ('aplay -l', 'cat /proc/asound/cards', 'alsamixer', etc.)

My suspicion is that some way the wrong driver gets loaded for the device, maybe due to the newer Sound Server version? Any ideas on how I can proceed to further investigate this issue?

I also already tried some of the suggestions online:

Something which might me related: alsa-info.sh show the following error at the end of its output:

[    9.780003] i915 0000:00:02.0: fb0: i915drmfb frame buffer device
[    9.834137] HDMI HDA Codec ehdaudio0D2: Max dais supported: 3
[    9.837860] snd_soc_skl 0000:00:1f.3: Direct firmware load for a348-INTEL-EDK2-2-tplg.bin failed with error -2
[    9.837866] snd_soc_skl 0000:00:1f.3: tplg fw a348-INTEL-EDK2-2-tplg.bin load failed with -2, falling back to dfw_sst.bin
[    9.838035] snd_soc_skl 0000:00:1f.3: Direct firmware load for dfw_sst.bin failed with error -2
[    9.838039] snd_soc_skl 0000:00:1f.3: Fallback tplg fw dfw_sst.bin load failed with -2
[    9.838045] snd_soc_skl 0000:00:1f.3: Failed to init topology!
[    9.838049] snd_soc_skl 0000:00:1f.3: ASoC: failed to probe component -2
[    9.838075] skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: failed to instantiate card -2

If any other information is needed, please let me know!

(edit) I currently installed Ubuntu 19.04, which is working just fine.


4 Answers 4


I experience quite similar problems after upgrading Ubuntu 18.04 from kernel version 5.3.0-40 to 5.3.0-42. inxi shows the same sound server version.

I also have only the dummy audio device available and cat /proc/asound/cards says

 --- no soundcards ---

Not sure whether the kernel update is the reason, though. Tried a lot of multimedia stuff due to the Corona breakdown. This could have hampered audio as well.

Update: It seems originate from the kernel update. I booted in the old kernel and sound works!

A possible solution with setting a boot parameter is described here (not sure whether I'll follow that route): Ubuntu 18.04 audio disappeared after update

Update 2: Even kernel 5.3.0-45 does not seem to fix the issue (at least not for me). So, I added the following line to /etc/modprobe.d/alsa-base.conf as suggested from multiple sources (e.g. https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1868782):

 options snd-hda-intel dmic_detect=0

With that, speakers/headphone work. Internal mic will not be detected (but wasn't before, either).

For the time being, I use an external USB microphone as workaround. That one messed with the sound card ordering, however: Plugged microphone in -> no sound from speaker/headphone, unplugged -> speaker/headphone worked. So, I additionally added the lines

 options snd-usb-audio index=-1
 options snd-hda-intel index=-2

to /etc/modprobe.d/alsa-base.conf. Now, I have working sound input/output.

  • I did try adding the boot parameter, but for me it didn't work. Did you have any luck with it? Mar 20, 2020 at 15:29
  • I added the option to the config file (see above). Works for 5.3.0-45. Apr 4, 2020 at 9:53

I have a Dell 7391 with ubuntu 19.10 and this works for me:

  1. Edit /etc/default/grub

    sudo vi /etc/default/grub
  2. Find the line starting with GRUB_CMDLINE_LINUX_DEFAULT and append snd_hda_intel.dmic_detect=0 to its end. For example:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.dmic_detect=0"
  3. Update grub configuration

    sudo update-grub
  4. Reboot

Thank's to Gryu (https://askubuntu.com/a/1218119/687058), tomas (https://askubuntu.com/a/1218063/687058) and Zanna (https://askubuntu.com/a/19487)


I am running Ubuntu 20.04, on Dell Vostro 7590 with kernel version 5.6.0-1020-oem.

Here is what solved my problem.

  1. Install SOF firmware and topology binaries:
git clone -b stable-v1.5.1 https://github.com/thesofproject/sof-bin.git
cd sof-bin
sudo ./go.sh
  1. Blacklist snd-hda-interl and snd-soc-skl by adding following lines to /etc/modprobe.d/alsa-base.conf:
blacklist snd-hda-intel
blacklist snd-soc-skl

Note that if you have some other changes to that file, it is good to revert them (e.g. remove options snd_hda_intel dmic_detect=0).

  1. Reboot
  • not working with kernel 5.4 Aug 1, 2020 at 12:09
  • @AlexPunnen, does dmesg say something?
    – mkk
    Aug 2, 2020 at 9:17

This worked on my Dell Precision 7540 after having installed Ubuntu version 21.04 with kernel version 5.11: I followed this guide https://itsfoss.com/fix-sound-ubuntu-1304-quick-tip/.

The command that did it for me was: sudo alsa force-reload

I don't know why this command did it when reboots had no effect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .