0

I want to modify netplan-wpa@.service.

$sudo cp /lib/systemd/system/netplan-wpa@.service /etc/systemd/system/

Then I edited /etc/systemd/system/netplan-wpa@.service.What I changed was adding "-Dnl80211,wext" to last line.

$cat /etc/systemd/system/netplan-wpa@.service
[Unit]
Description=WPA supplicant for netplan %I
DefaultDependencies=no
Requires=sys-subsystem-net-devices-%i.device
After=sys-subsystem-net-devices-%i.device
Before=network.target
Wants=network.target

[Service]
Type=simple
ExecStart=/sbin/wpa_supplicant -Dnl80211,wext -c /run/netplan/wpa-%I.conf -i%I

$sudo systemctl daemon-reload
$sudo systemctl restart netplan-wpa@wlp2s0
$sudo systemctl status netplan-wpa@wlp2s0
● netplan-wpa@wlp2s0.service - WPA supplicant for netplan wlp2s0
   Loaded: loaded (/lib/systemd/system/netplan-wpa@.service; indirect; vendor preset: enabled)
   Active: active (running) since Wed 2020-03-18 15:10:35 JST; 30min ago
 Main PID: 1095 (wpa_supplicant)
    Tasks: 1 (limit: 4522)
   CGroup: /system.slice/system-netplan\x2dwpa.slice/netplan-wpa@wlp2s0.service
           └─1095 /sbin/wpa_supplicant -c /run/netplan/wpa-wlp2s0.conf -iwlp2s0

There is no "-Dnl80211,wext" in process line.systemd ignores /etc/systemd/system/netplan-wpa@.service.Should I change directly /lib/systemd/system/netplan-wpa@.service? When I edited /lib/systemd/system/netplan-wpa@.service,It worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.