23

I've been using Ubuntu 18.04 on my Thinkpad X1 Carbon 7th gen for some time now with the audio working just fine, but after running some updates yesterday it seems like the audio card has stopped working when I rebooted this morning, could this be related to each other?

dmsg output:

[   32.624585] skl_hda_dsp_generic skl_hda_dsp_generic: Unsupported HDAudio/iDisp configuration found
[   32.624590] skl_hda_dsp_generic: probe of skl_hda_dsp_generic failed with error -22

output from /var/log/apt/history.log:

Start-Date: 2020-03-17  09:30:06
Commandline: aptdaemon role='role-commit-packages' sender=':1.214'
Install: linux-image-5.3.0-42-generic:amd64 (5.3.0-42.34~18.04.1, automatic), linux-headers-5.3.0-42-generic:amd64 (5.3.0-42.34~18.04.1, automatic), linux-modules-extra-5.3.0-42-generic:amd64 (5.3.0-42.34~18.04.1, automatic), linux-headers-5.3.0-42:amd64 (5.3.0-42.34~18.04.1, automatic), linux-modules-5.3.0-42-generic:amd64 (5.3.0-42.34~18.04.1, automatic)
Upgrade: gir1.2-nm-1.0:amd64 (1.10.6-2ubuntu1.2, 1.10.6-2ubuntu1.4), linux-libc-dev:amd64 (4.15.0-88.88, 4.15.0-91.92), linux-headers-generic-hwe-18.04:amd64 (5.3.0.40.97, 5.3.0.42.99), libnm0:amd64 (1.10.6-2ubuntu1.2, 1.10.6-2ubuntu1.4), network-manager:amd64 (1.10.6-2ubuntu1.2, 1.10.6-2ubuntu1.4), linux-image-generic-hwe-18.04:amd64 (5.3.0.40.97, 5.3.0.42.99), linux-signed-generic-hwe-18.04:amd64 (5.3.0.40.97, 5.3.0.42.99), linux-generic-hwe-18.04:amd64 (5.3.0.40.97, 5.3.0.42.99), network-manager-config-connectivity-ubuntu:amd64 (1.10.6-2ubuntu1.2, 1.10.6-2ubuntu1.4), code:amd64 (1.42.1-1581432938, 1.43.0-1583783132), linux-firmware:amd64 (1.173.15, 1.173.16), docker-ce:amd64 (5:19.03.7~3-0~ubuntu-bionic, 5:19.03.8~3-0~ubuntu-bionic), docker-ce-cli:amd64 (5:19.03.7~3-0~ubuntu-bionic, 5:19.03.8~3-0~ubuntu-bionic)
End-Date: 2020-03-17  09:31:51

Start-Date: 2020-03-18  06:58:27
Commandline: /usr/bin/unattended-upgrade
Remove: linux-headers-5.3.0-28:amd64 (5.3.0-28.30~18.04.1), linux-headers-5.3.0-28-generic:amd64 (5.3.0-28.30~18.04.1)
End-Date: 2020-03-18  06:58:27

Start-Date: 2020-03-18  06:58:30
Commandline: /usr/bin/unattended-upgrade
Remove: linux-modules-extra-5.3.0-28-generic:amd64 (5.3.0-28.30~18.04.1)
End-Date: 2020-03-18  06:58:31

Start-Date: 2020-03-18  06:58:36
Commandline: /usr/bin/unattended-upgrade
Remove: linux-modules-5.3.0-28-generic:amd64 (5.3.0-28.30~18.04.1), linux-image-5.3.0-28-generic:amd64 (5.3.0-28.30~18.04.1)
End-Date: 2020-03-18  06:58:40

Start-Date: 2020-03-18  06:58:48
Commandline: /usr/bin/unattended-upgrade
Upgrade: libcephfs2:amd64 (12.2.12-0ubuntu0.18.04.4, 12.2.12-0ubuntu0.18.04.5)
End-Date: 2020-03-18  06:58:49

Start-Date: 2020-03-18  06:58:53
Commandline: /usr/bin/unattended-upgrade
Upgrade: libicu60:amd64 (60.2-3ubuntu3, 60.2-3ubuntu3.1)
End-Date: 2020-03-18  06:58:55

Start-Date: 2020-03-18  06:59:01
Commandline: /usr/bin/unattended-upgrade
Upgrade: librados2:amd64 (12.2.12-0ubuntu0.18.04.4, 12.2.12-0ubuntu0.18.04.5)
End-Date: 2020-03-18  06:59:02

Start-Date: 2020-03-18  06:59:08
Commandline: /usr/bin/unattended-upgrade
Upgrade: python3-apport:amd64 (2.20.9-0ubuntu7.11, 2.20.9-0ubuntu7.12)
End-Date: 2020-03-18  06:59:09

Start-Date: 2020-03-18  06:59:14
Commandline: /usr/bin/unattended-upgrade
Upgrade: python3-problem-report:amd64 (2.20.9-0ubuntu7.11, 2.20.9-0ubuntu7.12)
End-Date: 2020-03-18  06:59:15

Start-Date: 2020-03-18  06:59:18
Commandline: /usr/bin/unattended-upgrade
Upgrade: apport:amd64 (2.20.9-0ubuntu7.11, 2.20.9-0ubuntu7.12)
End-Date: 2020-03-18  06:59:21

Start-Date: 2020-03-18  06:59:24
Commandline: /usr/bin/unattended-upgrade
Upgrade: apport-gtk:amd64 (2.20.9-0ubuntu7.11, 2.20.9-0ubuntu7.12)
End-Date: 2020-03-18  06:59:25
26

So to answer my own question. After a lot of digging I finally managed to get my audio working again. After finding this thread https://bugs.archlinux.org/task/64720 I tried temporarily adding the boot parameter snd_hda_intel.dmic_detect=0 by following this guide: How do I add a kernel boot parameter? to verify that it worked. It solved my problem, and I added the key permanently now, and the fix seems to persist after reboot.

| improve this answer | |
  • 1
    Thanks, this was the correct answer for me. – kkazakov Mar 18 at 9:26
  • 1
    Thank you so much! Worked for me on Ubuntu 19.10 after updating today and getting no sound card detected and dummy output for sound. – Stephen Niedzielski Mar 19 at 15:52
  • 1
    Did not work for me on Ubuntu 19.10., but was able to fix it anyways. See my answer askubuntu.com/a/1218725/748806 – Doc Mar 20 at 11:20
  • 1
    Super, thanks a lot, this worked for me (also 18.04 on X1C7)! :-))) – Stefan Mar 20 at 17:56
  • 1
    Thanks! It worked for me on my Dell Vostro 7590. Audio stopped working after upgrading kernel from 5.3.0-40 to 5.3.0-42 on Xubuntu 19.04, the boot parameter fixed it. – lorenzo-s Mar 21 at 12:49
1

I am on Ubuntu 19.10, Thinkpad X1C7 and had the same problem. Also, I was not able to shutdown anymore. I tried your own answer but it didn't help.

So I rolled back the kernel from 5.3.0.42-generic to 5.3.0.40-generic following this instruction: How to downgrade kernel after bad update (16.04)

After a reboot, it worked.

| improve this answer | |
  • 1
    Ubuntu 19.10 is probably as different story because it's not part of the certified hardware thing. Nice that you were able to fix it. – tomas Mar 23 at 12:44
  • While trying your solution on a Thinkpad X1C7, I get warned "Your are running a kernel and attempting to remove the same version". Is this warning part of the normal rolling-back workflow, or should I be suspicious about that? – Giorgio Mar 25 at 8:42
  • I observed the warning as well and continued. It should automatically roll back to an older kernel version, if one is installed! Maybe check that you are not removing the only version you have. – Doc Mar 25 at 9:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.