0

My Ubuntu system has stopped producing any sound what-so-ever, since I used a set of Bluetooth headphones with it, though the Bluetooth may be unrelated, it was just the last thing I used.

First the obvious: No the headphones are not still connected, and Bluetooth is switched off. It is not muted in the system tray, and i do not have the program making the sound muted. I have tried several sources including the sound test in settings/sound. I have done both sudo apt-get update and sudo apt-get upgrade as well as rebooted the system.

I have also tried:

  1. alsamixer shows the audio channels to be not unmuted and with volume, also auto-mute is disabled.
  2. pavucontrol shows several port options (headphones, speakers and line out) ports. Each showing a volume metre that is responsive to the audio sources on the computer, and the line out and headphones ports are responsive to having something plugged into them; registering plugged in/unplugged but no sound through either.
  3. input devices in both the sound tab of settings, and pavucontrol is responsive to sounds I make, so it appears the microphone is working.
  4. I have reinstalled pulseaudio and alsa-base using
sudo apt remove --purge alsa-base pulseaudio
sudo apt install alsa-base pulseaudio

as well as reloading alsa with

sudo alsa force-reload

Everything appears perfectly normal, except I get no sound output from speakers or headphones.

1
  • To check if the problem is some configuration in your user profile, try creating another user and login with that user. If sound works there, then at least you know that there's something in ~/.config or some other folder there that's causing the issue. – To Do Mar 18 '20 at 8:17
1

I had a similar issue once and what solved it was resetting Pulseaudio to default settings.

You may try: mv ~/.config/pulse ~/.config/pulse.bak and rebooting or logging out and then in again.

If sound returns, then you may delete the pulse.bak file rm ~/.config/pulse.bak

1
  • Thanks for the suggestion. I tried, this and had seen it as a potential solution elsewhere. Did not solve the problem for me though. – FinleyGibson Mar 17 '20 at 20:31
0

So I managed to finally get the sound working by re-installing the HDA sound drivers for my machine using

sudo apt install linux-modules-extra-`uname -r`

seen here.

At least i believe this was the solution. Sound just started working, and this was the last significant thing i remember doing. Would be great if someone could confirm this as a probable solution.

To anyone experiencing similar issues, you can check your sound drivers using inxi -A.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.