0

I have been trying to solve this issue for some time now but I can't get any solution I am just trying to install Wine for Play on Linux oficially when I first installed play on linux wine was automatically installed but I got a please wait while the virtual drive is being created eror so I did what the page below told me to do which is to remove libz.so libz.so.1 libz.so.1.2.3.4 libz.so.1.2.7 I did and the problem started there.Firstly I was suggested to install i386 I did with the command:

echo "foreign-architecture i386" > /etc/dpkg/dpkg.cfg.d/multiarch

I get the eror:

bash: /etc/dpkg/dpkg.cfg.d/multiarch: Permission denied

After that I was suggested to execute these commands:

  • echo "foreign-architecture i386" > /etc/dpkg/dpkg.cfg.d/multiarch

and

  • sudo dpkg --foreign-architecture i386

I simply get no output out of any of these. I have already tried to use the command:

sudo dpkg --add-architecture i386

With the output of:

dpkg: error: configuration error: /etc/dpkg/dpkg.cfg.d/architectures:1: unknown option 'foreign-architecture'

I have tried to check if it is already installed or not via the command:

sudo dpkg --print-foreign-architectures

which I get the same output with the previously mentioned command. I have tried to purge it with the command:

sudo apt-get purge ".:i386"

Which returned the eror code of:

E: Sub-process dpkg --set-selections returned an error code (2)
E: Couldn't record the approved state changes as dpkg selection states

Than I tried to remove the disturbing files with:

sudo rm /etc/dpkg/dpkg.cfg.d/multiarch 

Which I receive the error:

rm: cannot remove '/etc/dpkg/dpkg.cfg.d/multiarch'

Than I tried to use another command to remove the dısturbing files:

rm /etc/dpkg/dpkg.cfg.d/architectures

Which gave me the same error message.

I tried:

grep -ri foreignn /etc/dpkg/

Which returned no output.I tried:

sudo apt-get install libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386 libxml2:i386 libasound2-plugins:i386 libsdl2-2.0-0:i386 libfreetype6:i386 libdbus-1-3:i386 libsqlite3-0:i386

Which was actually executed successfully. I then tried:

dpkg --get-selections | grep hold

Still no output from the terminal. Than i tried:

dpkg -l *wine*

Which returned the output:

dpkg-query: no packages found matching winehq.key

One of the other solutions I have tried is:

sudo apt-get install wine1.7

Putting the output:

`Reading package lists... Done`

Building dependency tree
Reading state information... Done Package wine1.7 is a virtual package provided by: winehq-staging 5.4~eoan winehq-stable 5.0.0~eoan winehq-devel 5.4~eoan wine1.6 1:1.8.4ubuntu1

You should explicitly select one to install.

E: Package 'wine1.7' has no installation candidate

I am terribly stuck in a loop hole and I can't download wine nor i386 or multiarch. I have tried many solutions and I know Play on Linux won't run without wine.

Thanks in advance.

SOLUTION PAGES I USED:

1