0

I'm using an HP Laptop (Model 15bs179tx), and Ubuntu 16.04 (dual boot with Windows 10 Pro). My Bluetooth is not functioning on Ubuntu. I have tried the following:

I purged and reinstalled bluez, blueman, bluetooth as per the answer here

As described in the comments of the answer, I'm not able to use Bluetooth Manager as all my options are grayed out, and clicking the activate options under adapters and devices produce no result.

Here is the output to lspci -knn | grep Net -A2; lsusb

03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:d723]
    DeviceName: WLAN
    Subsystem: Hewlett-Packard Company Device [103c:8319]
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 05c8:03ac Cheng Uei Precision Industry Co., Ltd (Foxlink) 
Bus 001 Device 002: ID 0bda:b009 Realtek Semiconductor Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Opening the Bluetooth application shows Bluetooth disabled. Although I have tried enabling Bluetooth using sudo systemctl enable bluetooth and restarting the services, it has been of no use. It's not an issue with my drivers because they worked perfectly okay on Ubuntu 18.04 LTS. (I had to revert back to 16.04 LTS, because of a separate issue).

Basically I'm stuck in the same issue as here, and have not found a solution yet (if you follow the comments). Any help will be appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.