1

I recently installed Ubuntu 18.04 on my Asus laptop with NVIDIA graphics and an Intel i5 CPU. ASUS ROG G531GD

I accidentally decreased my screen brightness to 0 in the battery settings before I could configure the Fn keys (they do not work by default).

So I restarted and shifted to console mode when the login screen appears by pressing Ctrl+Alt+F1 and after logging I insert the following command

xrandr | grep " connected" | cut -f1 -d " "

results in

Can't open display

I also tried to blindly type in terminal the following: xrandr --output "$(xrandr | grep " connected" | cut -f1 -d " ")" --brightness 1. nothing changed

How do I use the console mode to change my brightness level considering that xrandr wont work.

I can log into recovery mode.

  • Have you tried bypassing the NVIDIA driver (whichever version you have, you didn't provide the NVIDIA graphics adapter model or driver number) by interrupting GRUB and temporarily adding nomodeset to the line which chooses Linux? See ubuntuforums.org/showthread.php?t=1613132 . If that does not help, remove the NVIDIA drivers to force reversion to nouveau at the next boot with nvidia-installer --uninstall && sudo apt remove nvidia-* – K7AAY Mar 16 at 18:52
  • I feel that I can modify the battery settings instead. Is there a way to modify the battery settings stored in some txt/conf file? – Ekoji Mar 16 at 19:21
  • Can I get my FN keys to work at least? – Ekoji Mar 16 at 19:38
  • After logging in, the screen cuts to black. I cant even go to console mode – Ekoji Mar 17 at 4:30
1

xrandr does not work because there is no X session at the console. Hopefully changing /sys/class/backlight/intel_backlight/brightness value will restore the brightness immediately. You should try

sudo echo 100 > /sys/class/backlight/intel_backlight/brightness

You can find more about brightness control here.

| improve this answer | |
  • THanks I blind-typed it into the terminal and it worked – Ekoji Mar 17 at 14:35
  • @Ekoji That's a very exciting experience, glad to hear it worked. But thinking it over, how could you read Can't open display? – Quasímodo Mar 17 at 14:48
  • That was in the console. In fact, I could only open the console when I was asked to login with my password. After loggin in I could not open the console – Ekoji Mar 17 at 14:50
  • So I used the Ctrl+Alt+T to open the terminal and slowly blindtyped the whole sequence – Ekoji Mar 17 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.