0

I am trying to install FreeSurfer: ftp://surfer.nmr.mgh.harvard.edu/pub/dist/freesurfer/6.0.0/freesurfer-Linux-centos6_x86_64-stable-pub-v6.0.0.tar.gz

I am following these steps to install FreeSurfer: https://surfer.nmr.mgh.harvard.edu/fswiki/DownloadAndInstall

When I run following commands:

~/subjects$ freeview -v \
bert/mri/T1.mgz \
bert/mri/wm.mgz \
bert/mri/brainmask.mgz \
bert/mri/aseg.mgz:colormap=lut:opacity=0.2 \
-f \
bert/surf/lh.white:edgecolor=blue \
bert/surf/lh.pial:edgecolor=red \
bert/surf/rh.white:edgecolor=blue \
bert/surf/rh.pial:edgecolor=red

I get this error:

freeview: error while loading shared libraries: libvtkDomainsChemistry-7.1.so.1: cannot open shared object file: No such file or directory

I have tried most of the suggestions on prior listings.

~/subjects$ sudo apt-get install libvtkDomainsChemistry-7.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libvtkDomainsChemistry-7.1
E: Couldn't find any package by glob 'libvtkDomainsChemistry-7.1'
E: Couldn't find any package by regex 'libvtkDomainsChemistry-7.1'

Also, I have tried both,

$ sudo apt install libvtk7.1-qt

and

$ sudo apt install libvtk7.1

Both installed without error. However, when I try Freeview I got exact same error,

$ freeview -v \

bert/mri/T1.mgz \
bert/mri/wm.mgz \
bert/mri/brainmask.mgz \
bert/mri/aseg.mgz:colormap=lut:opacity=0.2 \
-f \
bert/surf/lh.white:edgecolor=blue \
bert/surf/lh.pial:edgecolor=red \
bert/surf/rh.white:edgecolor=blue \
bert/surf/rh.pial:edgecolor=red

freeview: error while loading shared libraries: libvtkDomainsChemistry-7.1.so.1: cannot open shared object file: No such file or directory

I am very new to Linux, any help appreciated!

  • What ubuntu version do you use? – Gryu Mar 16 at 17:11
  • Hello, I am using Ubuntu 19.10 – Peny Mar 16 at 17:41
  • Have you tried @Olimjon's solution? – Gryu Mar 16 at 17:48
  • Yes, unfortunately does not work. – Peny Mar 16 at 17:49
  • Try also sudo apt install libvtk7.1-qt – Gryu Mar 16 at 17:52
2

This library is included in libvtk7.1 package. Just do this:

sudo apt install libvtk7.1
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.