2

I have shared an NTFS disk between Ubuntu 18.04 LTS and Windows 10 (I use it to store data which I want to access from both systems (music, documents...)). When I am in Windows 10 I can RWX over all the files and folders with no problem but in Ubuntu I am unable to get it properly working.

  1. I managed to get automatic mount running according to this: Automatic NTFS Partition Mount on Startup
  2. I managed to fix error "Read-only file system" when deleting files by remounting according to this: How to make read-only file system writable? but it is not persistent and when I delete some file for example it just reappears after refreshing the file browser window.

According to ls -l the drive owner is root and all the files seem to have all the permissions even before remounting (in the second step) which is also weird.

I need to make all permissions working correctly and persistent for the drive. I've read some other answers to similar problems but I was unable to get any further (make it work).

  • 1
    @K7AAY IT DID (disabled everything you mentioned)! Excelent, thank you very much. I think you should make it into an answer so I can accept it. :) – eXPRESS Mar 16 at 16:11
  • 1
    @K7AAY It sort of does in terms of what must be done to get it working but the situation and symptoms of the problem were different therefore I suggest to keep this is a standalone question. When I was searching the solution it would not occur to me that this is connected and it might not occur to somebody with similar problem in the future. So please tell me if you think I should accept that other question as solution or not, my opinion is it would be beneficial to keep this question separate. – eXPRESS Mar 16 at 16:28
  • We'll see if the improvements made below are adequate to let other folks think it should be retained. – K7AAY Mar 16 at 16:36
  • @K7AAY Yup, your answer does it. I did use GUI for disabling the hibernation since its on the same setting page as Fast Boot in Windows 10 settings but I guess cmd does as well. Thanks again. :) – eXPRESS Mar 16 at 16:41
1

Please make sure you have disabled Fast Boot in your BIOS/Firmware setup, and also disabled Hibernation and Fast Startup in Windows, as they can cause this issue. As cl-netbox wrote in How to disable hibernation and fastboot from windows so dual boot works in Ubuntu 14.04 (with specific keystrokes and commands added here for ease of use), you must boot into Windows, disable hibernation and Fast Boot. How?

Open command prompt as administrator and execute:

powercfg /h off  

Open the "old" version of Windows Control Panel with Win+R. Go to the Power Settings and uncheck Fast Startup. If you don't see Fast Startup, enable Show Hidden Settings.

Shutdown the machine completely, do NOT reboot, by tapping Win then click on the power icon at far lower left; hold down Shift and click Shut down.

Boot into your BIOS/Firmware settings (they key for which which varies on different PCs) and select Ubuntu as default system. Now you can select the OS to boot from GRUB menu.

https://unix.stackexchange.com/questions/477733/is-it-necessary-to-disable-fast-boot-in-windows-to-dual-boot-with-linuxefistub/477740#477740 also provides useful detail.

| improve this answer | |
  • 1
    Wow man it took me ages to find your answer and only then i could fix this. I did disable the fast boot from regıular Windows 10 power settings though. It's hidden under Settings > System > Power & sleep > Choose what power button does > Change settings that are currently unavailble > and finally uncheck the "Turn on fast startup (recommended)". – Redu Jun 6 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.