I am mainly a Windows technician and am trying to install ubuntu server. Everything worked fine and I can log in using the shell but when I installed ubuntu-desktop it just refuses to start? I did try startx and I get the message "server already running" I tried "start gdm" (what is this supposed to do?) and it comes back with "Job is already running: gdm"

I know that the server version is not really for ubuntu-desktop but all our other servers are like that and I want it, is there any help out there?

Ps. the server is running on a VM install that my IT department made for me and I connect to the machine shell using "Tera Ter Web 3.1"


Perhaps, if you use gdm it should be GNOME.
With ubuntu-desktop correctly more using of lightdm and Unity.

I haven't experience with server version. But it looks like popular trouble with home folder permissions.

Once I was it done by just running Guest session, unlock administrator account, remove it, and create new one.

Other alternative:

sudo apt-get install --reinstall -f -m -u gdm
sudo dpkg-reconfigure gdm

Select gdm

sudo restart gdm

Same way appropriate also for lightdm ((use lightdm instead gdm))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.