Suddenly, I've started to get Dummy Output in Ubuntu 18.04 Sound settings.

I've tried all methods commonly found on the web, including reinstalling pulseaudio and alsa-base:

 sudo apt install --reinstall pulseaudio alsa-base

and modifying /etc/modprobe.d/alsa-base.conf to add the line:

options snd-hda-intel index=1

But nothing works reliably. ALSA seems to detect the audio card properly: aplay -l **** List of PLAYBACK Hardware Devices **** card 0: Generic_1 [HD-Audio Generic], device 0: ALC255 Analog [ALC255 Analog] Subdevices: 0/1 Subdevice #0: subdevice #0 card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0] Subdevices: 0/1 Subdevice #0: subdevice #0

But Pulseaudio won't fine the devices:

     pacmd list-cards
0 card(s) available.

Only the Dummy Output is shown:

    pacmd list-sinks
1 sink(s) available.
  * index: 0
    name: <auto_null>
    driver: <module-null-sink.c>
    state: RUNNING
    suspend cause: 
    priority: 1000
    volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
            balance 0.00
    base volume: 65536 / 100% / 0.00 dB
    volume steps: 65537
    muted: no
    current latency: 8.65 ms
    max request: 3 KiB
    max rewind: 3 KiB
    monitor source: 0
    sample spec: s16le 2ch 44100Hz
    channel map: front-left,front-right
    used by: 1
    linked by: 1
    configured latency: 18.75 ms; range is 0.50 .. 2000.00 ms
    module: 14
        device.description = "Dummy Output"
        device.class = "abstract"
        device.icon_name = "audio-card"

I'm at a loss here, not sure where what to check out next.

Link to the output of pulseaudio running in verbose mode: https://pastebin.cnx-software.com/?5d3d73271588c486#7hN1zJZUpgWkXhpUSGAnSw6767JU73SLBZKGihsLEseN

I can't see anything odd except "no streams found"

  • This is likely of no value, but I've a PC that regularly now reports no sound device and I've concluded it's hardware related for my pc. I made no changes that caused a change (but looked anyway in /var/log/apt/history.log, then booted a 'live' system and at first it worked flawlessly, but after a few more boots the 'live' system was reporting dummy too. My point is I'm suggesting booting/using a 'live' system to check your hardware if you're convinced there is no software change/cause.. (ie. your 'Suddenly' start made my think of my old pc)
    – guiverc
    Mar 15, 2020 at 12:40
  • I've been running Ubuntu 18.04 for one year and a half on my PC. It's possible an update or a package I installed broke audio support. I just don't know, but it may be worth trying a live CD to make sure the hardware is still OK. Maybe I should have also mentioned that it all started when I disoovered I was unable to play YouTube videos in Firefox or Chrome. It would just show one frame, and I could also skip anywhere to the video to show one frame. Then I discovered Ihad no audio either. So It's possible something in Ubuntu multimedia subsystem is broken.
    – cnxsoft
    Mar 15, 2020 at 12:58


You must log in to answer this question.

Browse other questions tagged .