i installed Netbeans on Ubuntu 11.10 following these instructions: http://pasindudps.blogspot.com/2011/10/installing-netbeans-ide-in-ubuntu-1110.html.

It worked perfectly fine (creating projects, open projects, compile, run...) but after restarting netbeans started normally and it is shown as a running application in unity-panel but I can't access the programm.

I uninstalled and reinstalled it, it worked once but failed after restart.

Has anyone an idea what might be the problem here?

Thanks in advance. Regards

  • Possible permission problem, what happens when you run from terminal might show you an error? – 0x7c0 Apr 13 '12 at 15:40
  • Adding information to the previous comment: open a terminal (CTRL+ALT+T), type cd netbeans*/bin, then type ./start and check for any useful message. Maybe netbeans runs correctly but starts minimized for some reason, maybe it's a java-related problem (you can check your java version by running in a terminal: java -version) – Mr. Pixel Apr 13 '12 at 16:10
  • thanks for you help. i tried to run netbeans from terminal, no errors occured. it started normally, is shown as active programm in unity-starter but i can't access it. java version is 1.6.0_23. – ubuntumazze Apr 17 '12 at 13:20
  • Have you found a solution for this? – AntonioCS Jul 19 '12 at 9:23
  • I did sudo su and then ran netbeans. It worked so it must be some config for my normal user – AntonioCS Jul 19 '12 at 9:27

I changed




in netbeans-7.1/etc/netbans.conf on Ubuntu 12.04

It worked.

  • 1
    didn't work either. tried every jdk i've installed. but thanks anyways. – ubuntumazze Apr 25 '12 at 16:38

Install from software center, and tell us if is it working. Always you can, install preferably from software center =)

  • Netbeans is not present in the 11.x repositories (anymore?). My bet would be the fact that Oracle is sponsoring the project. It's a true shame, since Netbeans is relatively superior compared to Eclipse in terms of stability & performance, deployment, and ease of use. – Mr. Pixel Apr 13 '12 at 16:08
  • 1
    Very sorry for my answer, I'm in ubuntu 12.04 and it is present and I figured that will be present in 11.10. – Carlos Soriano Sánchez Apr 13 '12 at 16:21
  • You don't have to be sorry, especially if Netbeans is present in 12.04! That's some good news here! :) I did explicitely mention Ubuntu 11.x in my comment however, because I haven't taken a look at Ubuntu 12.04 yet. – Mr. Pixel Apr 13 '12 at 19:05
  • 2
    oh, I encourage you to try ubuntu 12.04, is still in beta, but it's stable enough for me – Carlos Soriano Sánchez Apr 13 '12 at 20:16
  • I'm impatient, but I do want to wait for the final release. I can't take the risk of running into bugs while working. :) – Mr. Pixel Apr 14 '12 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.