1

I'm new to Linux and Ubuntu and was not able to figure this out (even though there are other posts about this). I had no issues with the Wifi for 1 week after setting up the Dual boot. Then, my laptop overheated strongly so I had to reboot into Windows (maybe some changes/resets to defaults happened there). When then booting into Ubuntu again, I suddenly encountered "No Wi-Fi Adapter Found". I've tried various things but nothing worked. I'd be very thankful for advice.

  • Ubuntu 18.04.4 LTS
  • Dual Boot with Windows (booting into Windows, the WiFi works)
  • Secure Boot Disabled in Bios
  • Kernel: 5.3.0-40-generic
  • Network controller: Intel Corporation Wireless-AC 9560
  • Selected additional drivers: backport-iwlwifi-dkms
  • linux-firmware is up to date: 1.173.16

Some other infos:

lspci -knn | grep Net -A3; rfkill list
00:14.3 Network controller [0280]: Intel Corporation Wireless-AC 9560 [Jefferson Peak] [8086:a370] (rev 10)
    Subsystem: Bigfoot Networks, Inc. Device [1a56:1552]
    Kernel modules: iwlwifi
00:15.0 Serial bus controller [0c80]: Intel Corporation Device [8086:a368] (rev 10)
    Subsystem: Acer Incorporated [ALI] Device [1025:1343]
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

I also tried installing backport-iwlwifi like here and here. However, I can't execute make -j4, getting stopped by these errors:

Building modules, stage 2.
MODPOST 6 modules
ERROR: "__x86_indirect_thunk" [/home/julius/backport-iwlwifi/net/mac80211/mac80211.ko] undefined!
ERROR: "__x86_indirect_thunk" [/home/julius/backport-iwlwifi/net/wireless/cfg80211.ko] undefined!
ERROR: "__x86_indirect_thunk" [/home/julius/backport-iwlwifi/drivers/net/wireless/intel/iwlwifi/xvt/iwlxvt.ko] undefined!
ERROR: "__x86_indirect_thunk" [/home/julius/backport-iwlwifi/drivers/net/wireless/intel/iwlwifi/mvm/iwlmvm.ko] undefined!
ERROR: "__x86_indirect_thunk" [/home/julius/backport-iwlwifi/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko] undefined!
ERROR: "__x86_indirect_thunk" [/home/julius/backport-iwlwifi/compat/compat.ko] undefined!
make[5]: *** [scripts/Makefile.modpost:92: __modpost] Error 1
make[4]: *** [Makefile:1659: modules] Error 2
make[3]: *** [Makefile.build:13: modules] Error 2
make[2]: *** [Makefile.real:100: modules] Error 2
make[1]: *** [Makefile:43: modules] Error 2
make: *** [Makefile:30: default] Error 2

I also tried this one here but it did not work: http://ubuntuhandbook.org/index.php/2018/08/no-wifi-adapter-found-hp-laptops-ubuntu-18-04/

3
  • Reboot. At the GRUB menu, select an earlier kernel version than 5.3.0-40. Does the wireless work now? If not, edit your question to show the result of the terminal command: dmesg | grep iwl Welcome to Ask Ubuntu.
    – chili555
    Mar 13, 2020 at 14:33
  • Thanks a lot @chili555. Switching back to 5.3.0-28-generic solved the problem.
    – jollycat
    Mar 14, 2020 at 8:22
  • I have added a short summary as answer below. It seems like I can't tag you there though @chili555. I'm sorry for that.
    – jollycat
    Mar 14, 2020 at 8:36

1 Answer 1

1

@chili555 answered this question. Here once more for everyone:

When booting into Ubuntu (where Ubuntu is the first boot option as specified in UEFI, i.e. the computer automatically boots into Ubuntu when you start it), press ESC once. You will get to the GRUB Menu. It will look like below if you are at the right spot (picture is from here). Don't press ESC several times, otherwise you may get to the GRUP Shell / command line, where you don't want to be.

enter image description here

Navigate to Advanced options for Ubuntu and select the older Kernel that is still there. Press enter and the computer will boot into this older Kernel. Then, you can check if the Wifi works again. In my case, it did.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .