0

I'm quite new to OpenWRT and I'm facing some problems here.

I set up the OpenVPN server on a Ubuntu 16.04 PC using the OpenVPN Access Server web GUI, and correspondingly I got the client profile client.ovpn. Also I enabled "Google Authenticator Multi-Factor Authentication". When I configured as a client using client.ovpn, it worked perfectly on my phone, my other PC, but it just failed when I tried to start a client on OpenWRT on my router.

According to https://openvpn.net/vpn-server-resources/connecting-to-access-server-with-linux/, I used openvpn --config client.ovpn --auth-user-pass --auth-retry interact to start a connection, and I was prompted for a username and a password, which makes sense, but then I was never prompted for the authenticator code. Actually when I looked at the response, it did ask me for a code, but I never had a place to enter it. Instead, it asked to enter the username again, thus dropping into a loop. See below: (the forth line from the bottom)

root@OpenWrt:/etc/openvpn# openvpn --config client_gui.ovpn --auth-retry interact
Mon Mar  9 19:01:18 2020 Unrecognized option or missing or extra parameter(s) in client_gui.ovpn:124: static-challenge (2.4.7)
Mon Mar  9 19:01:18 2020 OpenVPN 2.4.7 mipsel-openwrt-linux-gnu [SSL (mbed TLS)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD]
Mon Mar  9 19:01:18 2020 library versions: mbed TLS 2.16.3, LZO 2.10
Enter Auth Username:london
Enter Auth Password:
Mon Mar  9 19:01:24 2020 WARNING: --ns-cert-type is DEPRECATED.  Use --remote-cert-tls instead.
Mon Mar  9 19:01:24 2020 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Mon Mar  9 19:01:24 2020 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Mon Mar  9 19:01:24 2020 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Mon Mar  9 19:01:24 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]192.168.8.222:1194
Mon Mar  9 19:01:24 2020 Socket Buffers: R=[163840->163840] S=[163840->163840]
Mon Mar  9 19:01:24 2020 UDP link local: (not bound)
Mon Mar  9 19:01:24 2020 UDP link remote: [AF_INET]192.168.8.222:1194
Mon Mar  9 19:01:24 2020 TLS: Initial packet from [AF_INET]192.168.8.222:1194, sid=fb509f08 f4ae8b1f
Mon Mar  9 19:01:24 2020 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Mon Mar  9 19:01:24 2020 VERIFY OK: depth=1, CN=OpenVPN CA
Mon Mar  9 19:01:24 2020 VERIFY OK: nsCertType=SERVER
Mon Mar  9 19:01:24 2020 VERIFY OK: depth=0, CN=OpenVPN Server
Mon Mar  9 19:01:24 2020 Control Channel: TLSv1.2, cipher TLS-ECDHE-RSA-WITH-AES-256-GCM-SHA384, 2048 bit key
Mon Mar  9 19:01:24 2020 [OpenVPN Server] Peer Connection Initiated with [AF_INET]192.168.8.222:1194
Mon Mar  9 19:01:25 2020 SENT CONTROL [OpenVPN Server]: 'PUSH_REQUEST' (status=1)
Mon Mar  9 19:01:25 2020 AUTH: Received control message: AUTH_FAILED,CRV1:R,E:PG_09HT0rZcjdFd6GnA:bG9uZG9u:Enter Authenticator Code
Mon Mar  9 19:01:25 2020 SIGUSR1[soft,auth-failure] received, process restarting
Mon Mar  9 19:01:25 2020 Restart pause, 5 second(s)
Enter Auth Username:

How can I solve this problem? Is there anything to be modified in client.ovpn? Thank you!

  • 1
    Which release of Ubuntu? – K7AAY Mar 10 at 17:42
  • @K7AAY Ubuntu 16.04 – Herricane Mar 10 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.