2

This is what I ran which worked:

sudo apt install curl

but when running the command alone it does not work:

curl

enter image description here

6
  • 1
    I am sorry, check again please – Adeena Lathiya Mar 8 '20 at 7:07
  • 1
    Hi @AdeenaLathiya actually the install process never completed successfully. Look at the last lines, it failed to download and install curl. You need to follow the instructions mentioned exactly at the end that state to run sudo apt-get update --fix-missing – Luis Alvarado Mar 8 '20 at 7:16
  • @adeena-lathiya If you read the last few lines carefully, it says, failed to fetch libcurl4_7.58 and curl_7.58 packages. For some reason the packages are not being downloaded. The last line ask you to try sudo apt update OR sudo apt install --fix-missing. – Jags Mar 8 '20 at 7:19
  • 1
    Are you using some proxy? – Kulfy Mar 8 '20 at 7:21
  • What do u mean by term proxy? I am sorry i am new at this – Adeena Lathiya Mar 8 '20 at 8:34
1

Your curl isn't getting installed although the process is getting completed (look at the last 3 lines). The error code 403 as rightly pointed out in the comments, and thus either the server is down for maintenance or you're trying to access internet through a proxy that is not allowing you to do so. This is why it's showing curl not not found!

2
  • The error code was 403 not 404. – Kulfy Mar 8 '20 at 7:43
  • Oh I'm really sorry I didn't observe that... Removing my answer now! – imperial-lord Mar 8 '20 at 7:46
0

the problem was with the software update. I just updated my ubuntu and now the command has been installed. Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.