4

I have Kubuntu 19.10 installed and then I installed gnome through apt thus having sddm and gdm3, my problem is that on gdm3 on the login screen I can only select plasma or ubuntu but can't find Wayland options while when I enable sddm I can select plasma, plasma on Wayland, ubuntu, ubuntu on Wayland. I tried editing: /etc/gdm3/custom.conf by commenting out WaylandEnable=false

#WaylandEnable=false

and also tried setting it to true same behavior

WaylandEnable=true

I have an iGPU and a dedicated Nvidia GPU running with the proprietary driver, selecting intel or nvidia through prime-select doesn't change anything and the Wayland sessions on both plasma and ubuntu work as expected through sddm

Edit: this question No option to switch from xorg to Wayland on Ubuntu 17.10 login isn't the same as mine because their response is that Wayland isn't compatible with the hardware but if I start Wayland session manually before logging in using :

XDG_SESSION_TYPE=wayland dbus-run-session gnome-session

the gnome Wayland session starts fine, my only problem is that I can't find it listed when pressing the gear icon on gdm

7
  • 3
    Does this answer your question? No option to switch from xorg to Wayland on Ubuntu 17.10 login – user535733 Mar 7 '20 at 2:05
  • • Could you expand on "I installed gnome through apt"? What was the exact command? • While troubleshooting quite often isn't an easy task, things are even more complicated when certain desktop environments are present at the same time. • While you don't seem to have problems with Wayland during your Plasma session, Wayland was still seen as experimental at the time Kubuntu 19.10 was released. AFAIK, Wayland will not be the default even in Kubuntu 20.04. – DK Bose Mar 7 '20 at 2:18
  • 1
    if you don't remember, you can look through logs (/var/log/apt/history.log; personally I view using using view but less or other tools work too) assuming it doesn't show in your command history – guiverc Mar 7 '20 at 3:14
  • I found the command in the apt logs: apt-get install gnome-shell – Elias Teeny Mar 7 '20 at 3:39
  • 7
    If nvidia drivers are installed then gdm will blacklist Wayland session. You could edit the file that causes this though you can't use nvidia drivers in a Wayland session. /lib/udev/rules.d/61-gdm.rules, I.e comment out last line. – doug Mar 7 '20 at 4:50
2

Posting @doug 's comment as answer.

Wayland is disabled by gnome devs on nvidia proprietery drivers due to instability of GLX applications with that recipe. You can manually remove or comment the DRIVER=="nvidia" rule at /lib/udev/rules.d/61-gdm.rules

See comment here: https://gitlab.gnome.org/GNOME/gdm/-/merge_requests/46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.