I've been having trouble resuming from suspend in Ubuntu 19.10. To try to locate and fix the issue, I tried using pm_trace as described here. However, when I set the pm_trace flag by running (as root) echo 1 > /sys/power/pm_trace, it fixes my resume issue until the next reboot. That is nice as a workaround, but I don't really want to be doing a pm_trace all the time. So my questions: what could pm_trace be doing that would fix my resume issue? What could this mean the problem is? And what could I do to fix such a problem?

1 Answer 1


The original resume issue was caused by asynchronous suspend/resume, which is enabled by default. The reason that resuming from suspend worked when using pm-trace is because pm-trace disables asynchronous suspend/resume as mentioned here. To disable asynchronous suspend/resume, it is only a matter of clearing the /sys/power/pm_async flag with echo 0 > /sys/power/pm_async. To have this work after reboots, create a systemd unit to clear the flag on every boot like this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .