2

Apparently Ubuntu has some problems with the kernel integration and more modern hardware. We installed these operating systems: Ubuntu 18.04 LTS, Ubuntu 19.10, Ubuntu 20.04, and also CentOS 8.1.1911, but the touch pad does not work on this Lenovo ThinkBook 14-IML.

We tried kernel version updating, and Gnome Tweaks ukku installed in Tweaks also checked all the settings.

Twice cross checked Synaptics installed or no improvement.

  • xserver-xorg-input-synaptics

  • installation done after that also no improvement.

  • ukuu --install-latest also done (Ubuntu Kernel Update Utility)

  • Upgrading the kernel to versions 5.5 and 5.5.7 using UKUU, which did not solve the problem.

  • We checked all firmware updates available that also couldn't succeed.

We tried all possibilities and couldn't succeed.

How may we troubleshoot this further to solve the touchpad failure?

  • have you tried: wiki.ubuntu.com/DebuggingTouchpadDetection – Gryu Mar 6 at 9:59
  • @Gryu Seems OP accidentally used flags instead of comments. Their response is "We tried but couldn't succeed." (from the declined flags) – Thomas Ward Mar 6 at 14:53
  • Please open a terminal window and run lsusb -v then highlight the text, copy the text, then return here and click edit. Paste the results into the question so we can see more detail on that laptop's hardware. Please do not use Add Comment. – K7AAY Mar 6 at 20:04
0

I installed Ubuntu on my Lenovo Thinkbook 15 IML and experienced exactly the same problem. Lenovo did not provide a solution for this "simple" task. As you mentioned, it is not rocket science and solution should have been provided by Lenovo Support Team since it is a basic functionality that should be guaranteed to work on any OS.

Anyway, Ubuntu community and its helpers are pretty amazing. After a few months struggling with the problem, Kai Heng-Feng found a solution and provided a test kernel which solved the issue. Now my Touchpad is working.

You can apply the test kernel published in comment #88 in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1853277

To apply this kernel you should download it and then go to Download folder and write the following sentence on a terminal:

sudo dpkg -i linux-image-5.9.0-rc4+_5.9.0-rc4+-4_amd64.deb

Restart your computer, and enjoy your working Touchpad!

P.S.: I believe this solution works for a Lenovo Thinkbook IIL series as well. Maybe the permanent solution will be published in a future Ubuntu official kernel.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.