2

I have installed Ubuntu Windows-Subsystem-for-Linux through Microsoft Store on my Windows 10 laptop, but it freezes randomly, for example when I run a command such as ls -l, gcc -o or even when the bash starts. What happens is that the whole bash just freezes, it doesn't run any command I type and many processes named bash, node and init appear in the Windows task manager which use close to 100% of the CPU. These processes can not be terminated through the Task Manager and they only close when I reboot the computer.

Task Manager

I have tried uninstalling and reinstalling Ubuntu WSL from the Microsoft Store, installing different Ubuntu WSL versions, updating Windows 10 and creating a new Windows User. This issue appeared suddenly, as some days ago everything was working fine.

  • I get something similar but mine only has 2Gb memory and a hard disk so I expect that. Is the disk running at 100% too? Seems OK on machines with more memory. – cup Mar 6 at 12:30
3

I had the same problem here. It seems to be linked to the latest Windows Update. I struggle to find the solution but it was actually quite simple : all you need to do is enable the Virtual Machine Platform option (not only the Linux subsystem option). You can find the instructions here. It worked like a charm for me, hope it will solve your problem !

| improve this answer | |
  • worked perfectly for me, for future reference the issue started occurring for me when using CLion with WSL after the latest windows update (didn't occur before with CLion) – Mor Paz Mar 18 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.