1

When I installed ubuntu 18.04 on my HP Pavilion 15z 6 months ago, I had trouble getting the wifi driver to work. Installing the rtl8821ce repo from this post solved my problem. 6 months later, I'm having trouble again with the "No wifi adapter found". I booted into my Windows 10 and the wifi works, so my wifi card is fine.

I uninstalled and reinstalled the rt18821ce from the kernel with no problems.

cd rtl8821ce/
sudo ./dkms-remove.sh
sudo /dkms-install.sh

Then rebooted, but still no connection to wifi card.

Following the instructions on this post, I removed the rt18821ce and then installed official ubuntu package.

sudo dpkg -i rtl8821ce-dkms_5.2.5.2.1.30816.20190425-0ubuntu1_all.deb

Rebooted, still have the issue.

Here's information on the details of my network card.

sudo lshw -C network

  *-network UNCLAIMED       
       description: Network controller
       product: RTL8821CE 802.11ac PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: ioport:f000(size=256) memory:fe900000-fe90ffff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eno1
       version: 15
       serial: f8:b4:6a:a7:75:ff
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=half firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:47 ioport:e000(size=256) memory:fe804000-fe804fff memory:fe800000-fe803fff

lspci -nnk | grep -A2 0280

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
    Subsystem: Hewlett-Packard Company RTL8821CE 802.11ac PCIe Wireless Network Adapter [103c:831a]
    Kernel modules: rtl8821ce

dmesg | grep -i firmware

[    0.474628] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    1.328217] acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge
[    2.721778] psmouse serio1: elantech: assuming hardware version 4 (with firmware version 0x4d5f02)
[    4.700397] Bluetooth: hci0: RTL: rtl: assuming no firmware upload needed
[    4.842078] [drm] Found VCN firmware Version: 1.73 Family ID: 18
[    4.842083] [drm] PSP loading VCN firmware
[  120.770143] usb 1-2.3: r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"

kernel version 5.0.0-37-generic

I have a log from journalctl -b if that helps.

  • Have you upgraded your kernel before wi-fi adapter ceased working in your system. – Gryu Mar 4 at 20:26
1

The issue was that BIOS Secure Boot was On.

Even though I did turn off Secure Boot 6 months ago, my BIOS settings reset to default(maybe it updated?), so I had to turn it off again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.