3

I'm trying to install Ubuntu 19.10 onto an Acer Aspire 3 laptop. I've made the bootable USB, booted from it and managed to get into the live environment. Everything works fine. I can the run the installer fine: select the language, keyboard layout, etc. Except, when I get to the stage of partitioning the hard drive and allocating disk space to Ubuntu, the hard drive isn't visible to the installer. The same thing happens if I load directly into the installer from the GRUB menu. I tried GParted also to see if that could detect the laptop's hard drive and it couldn't. In both cases, only the USB which the live environment is running from is visible. When I run

sudo fdisk -l

I get the following results:

</dev/loop* removed as not related to this problem>    

Disk /dev/sda: 14.62 GiB, 15682240512 bytes, 30629376 sectors
Disk model: Cruzer Blade
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x002557e0

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 30629375 30627328 14.6G c W95 FAT32 (LBA) 

which basically tells me the same (some loops and the 16GB USB drive).

I tried searching for problems with installing Ubuntu onto Acer Aspire 3's online and got this: https://community.acer.com/en/discussion/579165/aspire-3-fail-installing-ubuntu. A few other threads on UbuntuForums and AskUbuntu were discussing similar problems and all of them concluded that the problem was "stuck in weird RAID mode". In the BIOS, the SATA mode is initially Optane without RAID. No option to change SATA mode appears at first (what they're calling a 'hidden SATA mode') but can be accessed by pressing Ctrl + S in the 'Main' tab of the BIOS menu. Changed the SATA mode to AHCI and booted into the Ubuntu installer once again and I still had the same problem. I also updated the BIOS with drivers from the Acer website, which worked fine but also didn't solve the problem.

The fix listed at the bottom of the Acer Community thread is to reinstall Windows from a bootable USB but I would prefer not to do this if at all possible. Although, if nobody has another solution I'll try that and report back. Does anyone have any ideas? I can provide any information you need.

edit: I should add that I've tried to install Ubuntu 18.04 and Linux Mint Tricia and I came up against exactly the same problems (hard drive not visible to GParted or the Installer; installation impossible).

edit: I tried installing a fresh copy of Windows from a bootable USB and that also hasn't solved the problem. Still when I boot into the Ubuntu live environment the laptop hard drive is not visible.

  • 1
    Is the hard drive visible in Disks? – C.S.Cameron Mar 5 at 2:36
  • I'll have a look but not to my knowledge. – sbayl33 Mar 5 at 19:24
0

Your 14.62GiB Cruzer Blade(/dev/sda) is fully occupied by a single, 14.6G Windows 95 FAT32 partition (/dev/sda1).

You will have to reize or delete /dev/sda1 to get space on /dev/sda to install.

The /loop* mounts are just noise for this problem. I'll Edit them out.

You could use sudo lshw -c disk to see if the disk hardware is there.

| improve this answer | |
  • Isn't that the USB drive? – Organic Marble Mar 4 at 20:51
  • The Cruzer Blade is the USB drive. What's not appearing is the laptop hard drive. Also cheers for editing out the loops. – sbayl33 Mar 5 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.